• 东大OJ-1040-Count-快速幂方法求解斐波那契-


     

    Many ACM team name may be very funny,such as "Complier_Error","VVVVV".Oh,wait for a minute here.

    Is it "W W"+"V",or "W"+"V V V",or something others we can treat as?There are several ways we can treat this name "VVVVV" (5 'V's),as V V can be treat as a W.

    For 5 'V's,our have 8 ways.They are:

    1. V V V V V

    2. V W W

    3. W W V

    4. V W V V

    5. W V W

    6. W V V V

    7. V V W V

    8. V V V W

    The problem here is that for n 'V's,how many ways do we have to treat it?Because the answer may be too large, you should output the answer module by p.(If n is 0,then we have just one way.)

    输入

    There are multiple test cases. The first line of the input contains an integer M, meaning the number of the test cases.
    For each test cases, there are two integers n and p in a single line.
    You can assume that 0<=n<=2100000000, 0<p<=2009.

    输出

    For each test case, output the answer with case number in a single line.

    样例输入

    2
    5 5
    4 7

    样例输出

    3
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    #include<iostream>
    using namespace std;
    struct m{int a[2][2]; };
    m  mul(m a, m b,int p){
    	m c;
    	int i, j,k;
    	for (i = 0; i < 2;i++)
    	for (j = 0; j < 2; j++)
    	{
    		c.a[i][j] = 0;
    		for (k = 0; k < 2; k++)
    			c.a[i][j] +=( (a.a[i][k] %p)* (b.a[j][k]%p))%p;
    		c.a[i][j] %= p;
    	}
    	return c;
    }
    m go(m a, int n,int p){
    	if (n == 1)return a;
    	m b = go(a, n / 2, p);
    	m c = mul(b, b, p);
    	if (n % 2 == 1)c = mul(c, a, p);
    	return c;
    }
    int main(){
    	//freopen("in.txt", "r", stdin);
    	int t;
    	cin >> t;
    	m a = { 0, 1, 1, 1 };
    	while (t-- > 0){
    		int n, p;
    		cin >> n >> p;
    		if (n == 0){ cout << 1 << endl; continue; }
    		cout << go(a, n, p).a[1][1]<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    在linux系统中
    记录一次编译安装Pg_rman缺少依赖包的问题
    使用Patroni和HAProxy创建高可用的PostgreSQL集群
    Zabbix4.0国内下载源
    centos7部署postgresql集群高可用 patroni + etcd 之patroni篇
    centos7部署etcd集群
    docker-compose部署gitlab
    zabbix-agent主动模式和proxy
    docker-compose更新image命令
    shell脚本自动化安装pgsql10.5版本
  • 原文地址:https://www.cnblogs.com/weiyinfu/p/5013906.html
Copyright © 2020-2023  润新知