• 1140 Look-and-say Sequence (20 分)


    Look-and-say sequence is a sequence of integers as the following:

    D, D1, D111, D113, D11231, D112213111, ...
    

    where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

    Input Specification:

    Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

    Output Specification:

    Print in a line the Nth number in a look-and-say sequence of D.

    Sample Input:

    1 8
    

    Sample Output:

    1123123111
    
    作者: CHEN, Yue
    单位: 浙江大学
    时间限制: 400 ms
    内存限制: 64 MB
    代码长度限制: 16 KB
    #include<iostream>
    using namespace std;
    
    int main(){
        string s;
        int n,j;
        cin >> s;
        cin >> n;
        while(--n){
            string ans;
            int cnt = 0;
            char pre = s[0];
            for(int i = 0; i < s.size(); i++){
                if(s[i] == pre) cnt++;
                else{
                    ans += pre;
                    ans += cnt + '0';
                    pre = s[i];
                    cnt = 1;
                }            
            }
            if(cnt > 0){
                ans += pre;
                ans += cnt +'0';
            }
            s = ans;        
        }
        cout << s;
        return 0;
    }
  • 相关阅读:
    JavaScript—— scroolleftoffsetleft 系列的含义以及浏览器兼容问题
    GCD
    Treap
    快速* 模板
    线性筛素数
    珂朵莉树
    One Night
    长整数相加运算(内含减法)。。= =
    骑士周游 非完美版。。= =
    《Windows取证分析》
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10458565.html
Copyright © 2020-2023  润新知