• UVa_488 Triangle Wave


     Triangle Wave 

    In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

    Input and Output

    The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

    Each input set will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

    For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

    For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

    The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

    NOTE: There is a blank line after each separate waveform, excluding the last one.

    Sample Input

    1

    3
    2

    Sample Output

    1
    22
    333
    22
    1

    1
    22
    333
    22
    1

    View Code
    #include <stdio.h>
    int main()
    {
    int a, f, n;
    int i, j;
    scanf(
    "%d",&n);
    while(n--)
    {
    scanf(
    "%d",&a);
    scanf(
    "%d",&f);
    while(f--)
    {
    for(i =1; i <= a; i++)
    {
    for(j =0; j < i; j++)
    printf(
    "%d",i);
    printf(
    "\n");
    }
    for(i = a-1; i >=1; i--)
    {
    for(j =0; j < i; j++)
    printf(
    "%d",i);
    printf(
    "\n");
    }
    if(f)
    printf(
    "\n");
    }
    if(n)
    printf(
    "\n");
    }
    return0;
    }
  • 相关阅读:
    C# Attribute(中)——Attribute本质论
    计算机体系结构-内存调优IPC OOMK
    RHCA-RH442-Linux系统性能调优 (学习)
    Redhat 官方Performance_Tuning_Guide
    linux 内核官方文档
    运维博客---OOM
    lenky的个人站点 ----LINUX 内核进程
    kswapd0、kjournald、pdflush、kblocked、migration进程含义 转
    计算机体系结构 -内存优化vm+oom
    计算机体系结构-CPU
  • 原文地址:https://www.cnblogs.com/vongang/p/2114059.html
Copyright © 2020-2023  润新知