• HDU 4762 Cut the Cake(公式)


    Cut the Cake

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 263    Accepted Submission(s): 113


    Problem Description
    MMM got a big big big cake, and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries, not just for decoration). HZ is in charge of the decoration, and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that, MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat), and choose one piece first. MMM wants to know the probability that she can get all N strawberries, can you help her? As the cake is so big, all strawberries on it could be treat as points.
     
    Input
    First line is the integer T, which means there are T cases.
    For each case, two integers M, N indicate the number of her friends and the number of strawberry.
    (2 < M, N <= 20, T <= 400)
     
    Output
    As the probability could be very small, you should output the probability in the form of a fraction in lowest terms. For each case, output the probability in a single line. Please see the sample for more details.
     
    Sample Input
    2 3 3 3 4
     
    Sample Output
    1/3 4/27
     
    Source
     
    Recommend
    liuyiding
     

     公式为:n/m^(n-1)

    import java.util.Scanner;
    import java.math.BigInteger;
    
    public class Main{
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            int t = cin.nextInt();
            while(t!=0){
                t--;
                BigInteger m = cin.nextBigInteger();
                int n = cin.nextInt();
                BigInteger tmp=BigInteger.valueOf(n);
                BigInteger ans=m.pow(n-1);
                BigInteger x=ans.gcd(tmp);
                System.out.println(tmp.divide(x) + "/" + ans.divide(x));
            }
        }
    }
  • 相关阅读:
    我终于会手打lct了!
    [模板]Dijkstra-优先队列优化-单源最短路
    99999999海岛帝国后传:算法大会
    正在加载中。。。。。
    【题解】CF1054D Changing Array(异或,贪心)
    【题解】P4550 收集邮票(概率期望,平方期望)
    【题解】CF149D Coloring Brackets(区间 DP,记忆化搜索)
    【笔记】斜率优化 DP
    CSP2021 游记
    【题解】洛谷P1502 窗口的星星
  • 原文地址:https://www.cnblogs.com/twodog/p/12135341.html
Copyright © 2020-2023  润新知