• POJ1995 ZOJ2150 Raising Modulo Numbers【快速模幂】


    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 8010   Accepted: 4875

    Description

    People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

    Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

    You should write a program that calculates the result and is able to find out who won the game. 

    Input

    The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

    Output

    For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

    (A1B1+A2B2+ ... +AHBH)mod M.

    Sample Input

    3
    16
    4
    2 3
    3 4
    4 5
    5 6
    36123
    1
    2374859 3029382
    17
    1
    3 18132
    

    Sample Output

    2
    13195
    13
    

    Source



    问题链接POJ1995 ZOJ2150 Raising Modulo Numbers

    问题简述:参见上述链接。

    问题分析

    是一个单纯的模幂计算和求和问题,调用模幂计算函数即可

    不用快速模幂计算的话,时间上会超时。

    程序说明:函数powermod()是模幂计算函数。


    AC的C++语言程序如下

    /* POJ1995 ZOJ2150 Raising Modulo Numbers */
    
    #include <iostream>
    
    using namespace std;
    
    typedef unsigned long long ULL;
    
    // 模幂计算
    ULL powermod(ULL a, ULL n, ULL m)
    {
        ULL res = 1LL;
        while(n) {
            if(n & 1LL) {        // n % 2 == 1
                res *= a;
                res %= m;
            }
            a *= a;
            a %= m;
            n >>= 1;
        }
        return res;
    }
    
    int main()
    {
        int z, m, h, ai, bi, ans;
    
        cin >> z;
        while(z--) {
            cin >> m >> h;
    
            ans = 0;
            while(h--) {
                cin >> ai >> bi;
    
                ans += (int)powermod(ai, bi, m);
            }
            ans %= m;
            cout << ans << endl;
        }
    
        return 0;
    }



  • 相关阅读:
    vue项目中echarts使用渐变效果报错echarts is not defined
    vue cli 项目中设置背景图
    vue项目中使用echarts地图
    vue Echarts自适应浏览器窗口大小
    promise函数
    vue中路由传参的方式
    嵌套路由
    PHP——实验三 PHP表单交互
    PHP实验——实验二 php基本程序设计
    Ubuntu系统下安装完成tomcat进入管理页面
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563763.html
Copyright © 2020-2023  润新知