• 洛谷P1550 [USACO08OCT]打井Watering Hole


    P1550 [USACO08OCT]打井Watering Hole

    题目背景

    John的农场缺水了!!!

    题目描述

    Farmer John has decided to bring water to his N (1 <= N <= 300) pastures which are conveniently numbered 1..N. He may bring water to a pasture either by building a well in that pasture or connecting the pasture via a pipe to another pasture which already has water.

    Digging a well in pasture i costs W_i (1 <= W_i <= 100,000).

    Connecting pastures i and j with a pipe costs P_ij (1 <= P_ij <= 100,000; P_ij = P_ji; P_ii=0).

    Determine the minimum amount Farmer John will have to pay to water all of his pastures.

    POINTS: 400

    农民John 决定将水引入到他的n(1<=n<=300)个牧场。他准备通过挖若

    干井,并在各块田中修筑水道来连通各块田地以供水。在第i 号田中挖一口井需要花费W_i(1<=W_i<=100,000)元。连接i 号田与j 号田需要P_ij (1 <= P_ij <= 100,000 , P_ji=P_ij)元。

    请求出农民John 需要为连通整个牧场的每一块田地所需要的钱数。

    输入输出格式

    输入格式:

    第1 行为一个整数n。

    第2 到n+1 行每行一个整数,从上到下分别为W_1 到W_n。

    第n+2 到2n+1 行为一个矩阵,表示需要的经费(P_ij)。

    输出格式:

    只有一行,为一个整数,表示所需要的钱数。

    输入输出样例

    输入样例#1: 复制
    4
    5
    4
    4
    3
    0 2 2 2
    2 0 3 3
    2 3 0 4
    2 3 4 0
    输出样例#1: 复制
    9

    说明

    John等着用水,你只有1s时间!!!

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #define maxn 310
    using namespace std;
    int n,fa[maxn],num;
    struct node{
        int from,to,v;
        bool operator < (const node &a)const{
            return v<a.v;
        } 
    }e[maxn*maxn];
    int find(int x){
        if(x==fa[x])return x;
        return fa[x]=find(fa[x]);
    }
    int main(){
        scanf("%d",&n);
        int x;
        for(int i=0;i<=n;i++)fa[i]=i;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            e[++num].from=0;e[num].to=i;e[num].v=x;
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&x);
                if(i>j)e[++num].from=i,e[num].to=j,e[num].v=x;
            }
        }
        sort(e+1,e+num+1);
        int ans=0;
        for(int i=1;i<=num;i++){
            int f1=find(e[i].from),f2=find(e[i].to);
            if(f1!=f2){
                ans+=e[i].v;
                fa[f1]=f2;
            }
        }
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    java前三章总结
    Java入门第二章
    MYSQL 3306设置允许外网访问
    Lnmp Laravel搭建网站需要注意的几点:
    Linux 如何删除网站目录下的user.ini
    Linux Composer的安装
    lnmp切换PHP版本
    解决GitHub的raw.githubusercontent.com无法连接问题
    Linux 7系列默认不能连网的解决办法
    lnmp安装
  • 原文地址:https://www.cnblogs.com/thmyl/p/8977312.html
Copyright © 2020-2023  润新知