• 洛谷P2828 Switching on the Lights(开关灯)


    P2828 Switching on the Lights(开关灯)

    题目背景

    来源:usaco-2015-dec

    Farm John 最近新建了一批巨大的牛棚。这些牛棚构成了一个N*N的矩形网络。(1<n<100)

    然而bessie十分怕黑,他想计算可以把多少个牛棚的灯打开。

    题目描述

    有N*N个房间,组成了一张N*N的网格图,Bessie一开始位于左上角(1,1),并且只能上下左右行走。

    一开始,只有(1,1)这个房间的灯是亮着的,Bessie只能在亮着灯的房间里活动。

    有另外M条信息,每条信息包含四个数a,b,c,d,表示房间(a,b)里有房间(c,d)的灯的开关。

    请计算出最多有多少个房间的灯可以被打开

    输入输出格式

    输入格式:

    第一行,两个数:N,M(1<m<200000);

    第2-m+1行:坐标(x1,y1),(x2,y2)代表房间的坐标(x1,y1)及可以点亮的·房间的坐标(x2,y2);

    输出格式:

    一个数,最多可以点亮的房间数

    输入输出样例

    输入样例#1: 复制
    3 6
    1 1 1 2
    2 1 2 2
    1 1 1 3
    2 3 3 1
    1 3 1 2
    1 3 2 1
    
    输出样例#1: 复制
    5

    说明

    这里,如果你看得懂英文的话,这里有样例的说明。

    Here, Bessie can use the switch in (1,1)to turn on lights in (1,2)and (1,3). She can then walk to (1,3)and turn on the lights in (2,1),from which she can turn on the lights in (2,2). The switch in (2,3)is inaccessible to her, being in an unlit room. She can therefore illuminate at most 5 rooms.

    /*
        一个特别需要注意的细节:一个房间可以走多次!比较蠢的,我就另外写了一个宽搜来check这种情况
    */
    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<cstdlib>
    #define maxn 110
    using namespace std;
    int n,m,e[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
    bool vis[maxn][maxn],bri[maxn][maxn],hav[maxn][maxn],v[maxn][maxn];
    struct node{
        int x,y;
    }cur,nxt,map[maxn][maxn][10000];
    node make_node(int x,int y){
        node res;res.x=x;res.y=y;
        return res;
    }
    int main(){
        freopen("Cola.txt","r",stdin);
        scanf("%d%d",&n,&m);
        int a,b,c,d;
        for(int i=1;i<=m;i++){
            scanf("%d%d%d%d",&a,&b,&c,&d);
            map[a][b][++map[a][b][0].x].x=c;map[a][b][map[a][b][0].x].y=d;
            hav[a][b]=1;
        }
        queue<node>q;
        cur=make_node(1,1);vis[1][1]=1;bri[1][1]=1;
        q.push(cur);
        while(!q.empty()){
            while(!q.empty()){
                cur=q.front();q.pop();
                if(hav[cur.x][cur.y]){
                    for(int i=1;i<=map[cur.x][cur.y][0].x;i++){
                        int tx=map[cur.x][cur.y][i].x,ty=map[cur.x][cur.y][i].y;
                        if(bri[tx][ty])continue;
                        bri[tx][ty]=1;
                    }
                }
                for(int i=0;i<4;i++){
                    int xx=cur.x+e[i][0],yy=cur.y+e[i][1];
                    if(xx<1||xx>n||yy<1||yy>n)continue;
                    if(vis[xx][yy]||bri[xx][yy]==0)continue;
                    q.push(make_node(xx,yy));
                    vis[xx][yy]=1;
                }
            }
            queue<node>que;
            while(!que.empty())que.pop();
            memset(v,0,sizeof(v));
            que.push(make_node(1,1));v[1][1]=1;
            while(!que.empty()){
                cur=que.front();que.pop();
                for(int i=0;i<4;i++){
                    int xx=e[i][0]+cur.x,yy=e[i][1]+cur.y;
                    if(xx>n||xx<1||yy>n||yy<1)continue;
                    if(!v[xx][yy]&&bri[xx][yy]){
                        v[xx][yy]=1;
                        que.push(make_node(xx,yy));
                        if(!vis[xx][yy])
                        q.push(make_node(xx,yy)),vis[xx][yy]=1;
                    }
                }
            }
        }
        int cnt=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(bri[i][j])cnt++;
        printf("%d",cnt);
    }
  • 相关阅读:
    任务调度~Quartz.net实现简单的任务调试
    编译器错误~写JS还是谨慎点好
    编译器错误~不能向ObjectStateManager添加相同的键
    EF架构~将数据库注释添加导入到模型实体类中
    c++ pair类型
    Adobe dreamweaver 5.5安装过程
    c++函数作为参数传递
    c++ vector.clear()
    动态规划之装配线调度问题
    转:VS后缀名详解
  • 原文地址:https://www.cnblogs.com/thmyl/p/7795188.html
Copyright © 2020-2023  润新知