• 洛谷P3128 [USACO15DEC]最大流Max Flow


    P3128 [USACO15DEC]最大流Max Flow

    题目描述

    Farmer John has installed a new system of N-1N1 pipes to transport milk between the NN stalls in his barn (2 leq N leq 50,0002N50,000), conveniently numbered 1 ldots N1N. Each pipe connects a pair of stalls, and all stalls are connected to each-other via paths of pipes.

    FJ is pumping milk between KK pairs of stalls (1 leq K leq 100,0001K100,000). For the iith such pair, you are told two stalls s_isi​​ and t_iti​​, endpoints of a path along which milk is being pumped at a unit rate. FJ is concerned that some stalls might end up overwhelmed with all the milk being pumped through them, since a stall can serve as a waypoint along many of the KK paths along which milk is being pumped. Please help him determine the maximum amount of milk being pumped through any stall. If milk is being pumped along a path from s_isi​​ to t_iti​​, then it counts as being pumped through the endpoint stalls s_isi​​ and

    t_iti​​, as well as through every stall along the path between them.

    FJ给他的牛棚的N(2≤N≤50,000)个隔间之间安装了N-1根管道,隔间编号从1到N。所有隔间都被管道连通了。

    FJ有K(1≤K≤100,000)条运输牛奶的路线,第i条路线从隔间si运输到隔间ti。一条运输路线会给它的两个端点处的隔间以及中间途径的所有隔间带来一个单位的运输压力,你需要计算压力最大的隔间的压力是多少。

    输入输出格式

    输入格式:

    The first line of the input contains NN and KK.

    The next N-1N1 lines each contain two integers xx and yy (x e yxy) describing a pipe

    between stalls xx and yy.

    The next KK lines each contain two integers ss and tt describing the endpoint

    stalls of a path through which milk is being pumped.

    输出格式:

    An integer specifying the maximum amount of milk pumped through any stall in the

    barn.

    输入输出样例

    输入样例#1:
    5 10
    3 4
    1 5
    4 2
    5 4
    5 4
    5 4
    3 5
    4 3
    4 3
    1 3
    3 5
    5 4
    1 5
    3 4
    输出样例#1:
    9
    /*
        树上差分裸题
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 100000+15
    using namespace std;
    int n,k,tot,ans=-1;
    int dep[MAXN*2],sz[MAXN*2],top[MAXN*2],fa[MAXN*2],son[MAXN*2];
    int num,head[MAXN],c[MAXN];
    struct node{
        int to,pre;
    }e[MAXN*2];
    void Insert(int from,int to){
        e[++num].to=to;e[num].pre=head[from];head[from]=num;
        e[++num].to=from;e[num].pre=head[to];head[to]=num;
    }
    void dfs1(int now,int father){
        fa[now]=father;dep[now]=dep[father]+1;
        sz[now]=1;
        for(int i=head[now];i;i=e[i].pre){
            int to=e[i].to;
            if(to==father)continue;
            dfs1(to,now);
            sz[now]+=sz[to];
            if(!son[now]||sz[to]>=sz[son[now]])son[now]=to;
        }
    }
    void dfs2(int now,int father){
        top[now]=father;
        if(son[now])dfs2(son[now],father);
        for(int i=head[now];i;i=e[i].pre){
            int to=e[i].to;
            if(to==fa[now]||to==son[now])continue;
            dfs2(to,to);
        }
    }
    void dfs3(int now){
        for(int i=head[now];i;i=e[i].pre){
            int to=e[i].to;
            if(to==fa[now])continue;
            dfs3(to);
            c[now]+=c[to];
        }
        ans=max(ans,c[now]);
    }
    int lca(int a,int b){
        while(top[a]!=top[b]){
            if(dep[top[a]]<dep[top[b]])swap(a,b);
            a=fa[top[a]];
        }
        if(dep[a]>dep[b])swap(a,b);
        return a;
    }
    int main(){
        scanf("%d%d",&n,&k);
        int x,y;
        for(int i=1;i<n;i++){
            scanf("%d%d",&x,&y);
            Insert(x,y);
        }
        dfs1(1,0);
        dfs2(1,1);
        for(int i=1;i<=k;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            int Lca=lca(x,y);
            c[x]++;c[y]++;
            c[Lca]--;c[fa[Lca]]--;
        }
        dfs3(1);
        printf("%d",ans);
    }
  • 相关阅读:
    相似矩阵
    特征值和特征向量
    非齐次方程组的通解
    线性方程组解的性质和结构、基础解系
    高斯消元法求齐次线性方程的通解
    从零开始学 Web 之 HTML(三)表单
    从零开始学Web之HTML(二)标签、超链接、特殊符号、列表、音乐、滚动、head等
    从零开始学 Web 之 HTML(一)认识前端
    JavaScript基础(一)概述
    如何恢复windows的exe文件的默认打开方式
  • 原文地址:https://www.cnblogs.com/thmyl/p/7598078.html
Copyright © 2020-2023  润新知