• SDUT—2054数据结构实验之链表九:双向链表 (基本建立)


                                                                                                 点击打开链接

                                                                                                  数据结构实验之链表九:双向链表

                                                                                                                            Time Limit: 1000MS Memory Limit: 65536KB

    Problem Description

    学会了单向链表,我们又多了一种解决问题的能力,单链表利用一个指针就能在内存中找到下一个位置,这是一个不会轻易断裂的链。但单链表有一个弱点——不能回指。比如在链表中有两个节点A,B,他们的关系是B是A的后继,A指向了B,便能轻易经A找到B,但从B却不能找到A。一个简单的想法便能轻易解决这个问题——建立双向链表。在双向链表中,A有一个指针指向了节点B,同时,B又有一个指向A的指针。这样不仅能从链表头节点的位置遍历整个链表所有节点,也能从链表尾节点开始遍历所有节点。对于给定的一列数据,按照给定的顺序建立双向链表,按照关键字找到相应节点,输出此节点的前驱节点关键字及后继节点关键字。

    Input

    第一行两个正整数n(代表节点个数),m(代表要找的关键字的个数)。第二行是n个数(n个数没有重复),利用这n个数建立双向链表。接下来有m个关键字,每个占一行。

    Output

    对给定的每个关键字,输出此关键字前驱节点关键字和后继节点关键字。如果给定的关键字没有前驱或者后继,则不输出。
    注意:每个给定关键字的输出占一行。
               一行输出的数据之间有一个空格,行首、行末无空格。

    Example Input

    10 31 2 3 4 5 6 7 8 9 0350

    Example Output

    2 44 69

    Hint

    #include <iostream>
    #define max 20
    using namespace std;
    int a;
    struct node
    {
    	node *prior;
    	int num;
    	node *next;
    };
    struct node *CreateList(int n)
    {
    	node *head,*p,*q;
    	head=new node;
    	head->prior=head->next=NULL;
    	p=head;
    	for(int i=0;i<n;i++)
    	{
    		q=new node;
    		cin>>q->num;
    		q->next=NULL;
    		p->next=q;
    		q->prior=p;
    		p=q;
    	}
    	return head;
    }
    void Display(node *head,int m)
    {
    	node *p=head->next;
    		while(p!=NULL)
    		{
    			if(p->num==a)
    			{
    				if(p->next!=NULL&&p->prior!=head)
    				{
    					cout<<p->prior->num<<' '<<p->next->num<<endl;
    					break;//continue;用continune会死循环,基础知识(暑假做题的时候可能蒙了)
    				}
    				else if(p->next==NULL&&p->prior!=head)
    				{
    					cout<<p->prior->num<<endl;
    					break;//continue;
    				}
    				else if(p->next!=NULL&&p->prior==head)
    				{
    					cout<<p->next->num<<endl;
    				     break;//continue;
    				}
    				else//去掉这个else的判读,输入1 1 1 就出现bug
    					break;//continue;
    			}
    			else
    			    p=p->next;
    		}
    }
    int main()
    {
    	node *head;
    	int n,m;
    	cin>>n>>m;
    	head=CreateList(n);
    	while(m--)
    	{
    		cin>>a;
    	Display(head,m);
    	}
    	return 0;
    }//输入1 1 1时没有bug
    
    
    /***************************************************
    User name: YT1658506207邵雪源
    Result: Accepted
    Take time: 0ms
    Take Memory: 228KB
    Submit time: 2017-08-10 18:45:46
    ****************************************************/
    




  • 相关阅读:
    实践数据湖iceberg 第二课 iceberg基于hadoop的底层数据格式
    HTTP——系统学习
    电脑在内网如何快速同步时间
    interpreting non ascii codepoint
    Python 视频抽帧
    C# 静态实例的释放
    "Debian 安装" 国内巨慢解决方案全球首发解决方案
    QLIKVSENSE表达式/函数
    票到货未到财务处理方式
    管理好20人的团队
  • 原文地址:https://www.cnblogs.com/sxy201658506207/p/7586266.html
Copyright © 2020-2023  润新知