• acm 总结之大数加法


    以杭电1002为例

    A + B Problem II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 165579    Accepted Submission(s): 31635


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
     
    Sample Output
    Case 1: 1 + 2 = 3
     
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     
    Author
    Ignatius.L
     
     
    思路:计算机所能提供的加法很有限,不会超过100位,对于过于100位的甚至上千位上万位,我们只能寻求其他方法。这里我们采用数组存放各位数据,然后从个位开始模拟加法过程
    代码如下:

    #include "stdio.h"
    #include "string.h"
    #define N 1100
    char s1[N],s2[N];         //存入要加的2个字符串
    int a1[N],a2[N],a[N];   //a[N]存最后结果
    int main()
    {int i,j,k;
    int m,n;
    int q;
    int r;
    int l;
    int x;
    memset(s1,'0',sizeof(s1));  初始化s1
    memset(s2,'0',sizeof(s2));  初始化s2
    scanf("%d",&r);
    q=0;
    l=r;
    while(r--)
    {scanf("%s %s",s1,s2);
    m=strlen(s1);
    n=strlen(s2);

    x=0;

    memset(a1,0,sizeof(a1));
    memset(a2,0,sizeof(a2));
    memset(a,0,sizeof(a));

    for(i=0,j=m-1;i<m;i++)     //采用倒叙存储2数组各个位
    {a1[i]=s1[j]-'0';
    j--;}
    for(i=0,j=n-1;i<n;i++)
    {a2[i]=s2[j]-'0';j--;
    }


    if(m>n)
    k=m;
    else
    k=n;

    for(i=0;i<=k;i++)        //注意:为防止溢出,我们在加时在最后多加一次,即i<=k 而不是i<k
    {a[i]=a1[i]+a2[i]+x;
    if(a[i]>=10)
    { a[i]-=10;
     x=1;

    }
    else
    x=0;
    }
    q++;       //用来输出Case
    printf("Case %d: ",q);

    for(i=m-1;i>=0;i--)
    printf("%d",a1[i]);

    printf(" + ");

    for(i=n-1;i>=0;i--)
    printf("%d",a2[i]);

    printf(" = ");

    if(a[k]==0)k--;   //  特别注意:这里是用来判断 最后没有0输出的k值;即此步是为了在最后的结果输出时前边不输出0。 比如结果100,没有此步将输出0100


    for(i=k;i>=0;i--)
    printf("%d",a[i]);


    if(q!=l)            //此处为判断输出的格式 :相邻的两组数据空一行,最后一组数据的最后无空行
    printf(" ");
    else
    printf(" ");


    }

    return 0;
    }

  • 相关阅读:
    PE格式第五讲,手工添加节表
    PE格式第四讲,数据目录表之导入表,以及IAT表
    PE格式第三讲扩展,VA,RVA,FA(RAW),模块地址的概念
    PE文件格式详解,第三讲,可选头文件格式,以及节表
    PE文件格式详解,第二讲,NT头文件格式,以及文件头格式
    LVS
    Haproxy
    Nginx
    MySQL入门第一天——概述、数据表与约束操作
    NoSQL入门第五天——Java连接与整合操作
  • 原文地址:https://www.cnblogs.com/songmingtao/p/3223117.html
Copyright © 2020-2023  润新知