• Shuffle'm Up POJ


    Shuffle'm Up
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 15249   Accepted: 6962

    Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1

    Source

    题意:先给你两个长度一样的初始状态字符串s1,s2和一个大小为两倍的最终状态的s12,按照s2的第一个先放在s12第一个再依次是s1,s2,s1…,排完后再按照长度前一半是s1新状态,后一半是s2新状态, 重复以上操作,看得到s12是否有和 最初给的最终状态的s12相同的,有输出步数,没有就输出-1.

    思路:按照题目的顺序模拟即可,可以将每一个整合后的一个新的S12放进一个map里面,接下去如果模拟到了目标串就输出,如果发现模拟到的一个s12在map中出现过了并且不是和目标串的一样的话,那么这个时候出现了一个循环,无论如何也模拟不出目标串了,就可以输出-1了。注意那个'',一开始没有加这个wa了好几发。

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<cmath>
    #include<cstdlib>
    #include<queue>
    #include<set>
    #include<map>
    #include<vector>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define eps 1e-10
    #define PI acos(-1.0)
    #define _e exp(1.0)
    #define ll long long
    const int maxn=1e6+5;
    
    char a[maxn];
    char b[maxn];
    char c[maxn];
    char goal[maxn];
    int main()
    {
        int t;
        scanf("%d",&t);
        int ca=1;
        while(t--)
        {
            int n;
            int step=0;
            scanf("%d",&n);
            scanf("%s%s",a,b);
            scanf("%s",goal);
            map<string,int>mp;
            mp[goal]=1;
            while(1)
            {
                
                int pos=0;
                for(int i=0;i<n;i++)
                {
                    c[pos++]=b[i];
                    c[pos++]=a[i];
                }
                c[pos]='';
                step++;
        //        for(int i=0;i<2*n;i++)
        //            cout<<c[i];
                if(strcmp(c,goal)==0)
                {
                    cout<<ca++<<" "<<step<<endl;
                    break;
                }
                else if(mp[c]==1 && strcmp(goal,c))
                {
                    cout<<ca++<<" "<<-1<<endl;
                    break;
                }
                mp[c] = 1;
                int ii,k;
                for(ii=0;ii<n;ii++)   //分拆出s1与s2
                    a[ii]=c[ii];
                a[ii]='';
                
                for(k=0;ii<2*n;ii++,k++)
                    b[k]=c[ii];
                b[ii]='';
    
            }
        }
    }
  • 相关阅读:
    Java程序员之JS(一) 入门
    Java虚拟机(一)之开篇
    JDK/JRE/JVM区别与联系
    web开发视频(一)之环境准备
    Spring MVC 教程,快速入门,深入分析
    Java中“==和equals”的区别
    如何查看电脑最大支持多少GB内存
    win10 计算器calc命令打不开
    Win10图标显示不正常解决办法
    在系统右键菜单上添加程序
  • 原文地址:https://www.cnblogs.com/smallhester/p/9603976.html
Copyright © 2020-2023  润新知