• 二分--POJ-3258


    POJ-3258,二分

    题目

    Description

    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

    FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

    Input

    Line 1: Three space-separated integers: L, N, and M
    Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2
    2
    14
    11
    21
    17
    

    Sample Output

    4
    

    Hint

    Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

    思路

    题意,移除m个石子后,使相邻石子间的最短间距最大化。

    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <cstring>
    #include <cmath>
    #include <sstream>
    #include <algorithm>
    #include <set>
    #include <map>
    #include <vector>
    #include <queue>
    #include <iomanip>
    #include <stack>
    
    using namespace std;
    
    typedef long long LL;
    const int INF = 0x3f3f3f3f;
    const int N = 50005;
    const int MOD = 1e9 + 9;
    
    #define lson l, m, rt << 1
    #define rson m + 1, r, rt << 1 | 1
    
    int main()
    {
        int L, n, m;
        cin >> L >> n >> m;
        int a[N];
        a[n] = L;
        for(int i = 0;i < n;++i)
            cin >> a[i];
        sort(a, a + n + 1);
        int l = 0, r = L;
        //在L和原来石子间的最短距离间二分,这里偷懒,在L到0间二分
        while(l <= r)
        {
            int mid = (l + r) >> 1;
            int cnt = 0, s = 0;//计算移除的石子个数
            for(int i = 0;i <= n;++i)
            {
                if(mid >= a[i] - s)//满足这条不等式时,即表示石子i可移除,同时累加一段距离至不能移除
                    cnt++;
                else//累加至一段距离到不满足以上不等式时,就要从新的起点开始累加
                    s = a[i];
            }
            if(cnt <= m)//这里要取=,因为当我们取走最后一个石子的时候,因为石子被取走,所以不能得出答案
                //而这时候就是让cnt==m,把l加到最大值,就是刚好不能移除多一个石子的距离,就是答案了
                l = mid + 1;
            else
                r = mid - 1;
        }
        cout << l << endl;
        return 0;
    }
    
    

    参考

    https://blog.csdn.net/lyy289065406/article/details/6648558

  • 相关阅读:
    实践javascript美术馆的小案例,学习到的东西还是蛮多的,包括javascript编程中的预留退路、分离javascript、以及实现向后兼容等
    HTML5的渐变色 渐变的两种类型 createLinearGradient 和createRadialGradient
    (转)tar 解压缩命令
    VM下的linux系统上不了网?? 使用putty远程登录不上linux的解决方法?
    Js全等和等于
    JavaScript踩坑
    div height 自适应高度 占满剩余高度的方法
    iframe边距问题解决
    Vue.Js初学踩坑
    Linq.js表达式常见写法
  • 原文地址:https://www.cnblogs.com/shuizhidao/p/10446929.html
Copyright © 2020-2023  润新知