• USACO 1.2 Milking Cows


    Milking Cows

    Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

    Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

    • The longest time interval at least one cow was milked.
    • The longest time interval (after milking starts) during which no cows were being milked.

    PROGRAM NAME: milk2

    INPUT FORMAT

    Line 1: The single integer
    Lines 2..N+1: Two non-negative integers less than 1000000, the starting and ending time in seconds after 0500

    SAMPLE INPUT (file milk2.in)

    3
    300 1000
    700 1200
    1500 2100
    
    

    OUTPUT FORMAT

    A single line with two integers that represent the longest continuous time of milking and the longest idle time.

    SAMPLE OUTPUT (file milk2.out)

    900 300

    简单题:

    /*
    ID: shuyang1
    PROG: milk2
    LANG: C++
    */
    
    #include <iostream>
    #include <string>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    
    struct Node{
    int st;
    int et;
    };
    
    bool cmp(Node a,Node b)
    {
        if(a.st == b.st) return a.et<b.et;
        return a.st<b.st;
    }
    
    int main()
    {
        freopen("milk2.in","r",stdin);
        freopen("milk2.out","w",stdout);
       Node farm[5005];
       int i,j,k,n;
       cin>>n;
       for(i=0;i<n;i++)
            cin>>farm[i].st>>farm[i].et;
       sort(farm,farm+n,cmp);
       //for(i=0;i<n;i++) cout<<farm[i].st<<"  "<<farm[i].et<<endl;
       int start=farm[0].st,end=farm[0].et,maxtime=end-start;
       int maxidle=0;
       for(i=1;i<n;i++)
       {
           if(farm[i].st<=end && farm[i].et>end)
           {
                maxtime=maxtime>(farm[i].et-start)?maxtime:(farm[i].et-start);
                end=farm[i].et;
           }
           else if(farm[i].st>start && farm[i].et>end)
           {
               start=farm[i].st;
               maxidle=maxidle>(start-end)?maxidle:(start-end);
               end=farm[i].et;
           }
       }
    
       cout<<maxtime<<" "<<maxidle<<endl;
       return 0;
    }
    

      

  • 相关阅读:
    Mac下的类似apt-get的包管理工具Homebrew(笔记)
    C# 通过模拟http请求来调用soap、wsdl
    提高 ASP.NET Web 应用性能
    Ajax ContentType 列表大全
    关于多核游览器指定渲染内核的方法。
    Aspx页面模拟WebService功能
    Dapper完美兼容Oracle,执行存储过程,并返回结果集。
    简单爬虫,突破IP访问限制和复杂验证码,小总结
    在子线程中创建新的窗体,遇到的问题。
    【干货】jsMind思维导图整合Easyui的右键菜单
  • 原文地址:https://www.cnblogs.com/shenshuyang/p/2489810.html
Copyright © 2020-2023  润新知