• 07-语言入门-07-A Famous Music Composer


    描述
    Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:
    A    A#=Bb B      C     C#=Db D      D#=Eb E      F      F#=Gb G     G#=Ab
     
    Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.
    In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:
    Ab minor A# major A# minor C# major Db minor
    D# major D# minor Gb major Gb minor G# major
    Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.
     
     
    输入
    Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).

    输出
    For each case output the required answer, following the format of the sample.

    样例输入
    Ab minor
    D# major
    G minor

    样例输出
    Case 1: G# minor
    Case 2: Eb major
    Case 3: UNIQUE
     
    #include <stdio.h>
    #include <string.h>

    #define ARR_LEN 10

    int main()
    {
         char str1[ARR_LEN];
         char str2[ARR_LEN];
         int index = 0;
         while(scanf("%s %s",str1,str2) != EOF)
         {
              getchar();
              printf("Case %d: ",++index);
              if(strcmp(str1,"A#") == 0)
              {
                   printf("Bb %s ",str2);
              }
              else if(strcmp(str1,"Bb") == 0)
              {
                   printf("A# %s ",str2);
              }
              else if(strcmp(str1,"C#") == 0)
              {
                   printf("Db %s ",str2);
              }
              else if(strcmp(str1,"Db") == 0)
              {
                   printf("C# %s ",str2);
              }
              else if(strcmp(str1,"D#") == 0)
              {
                   printf("Eb %s ",str2);
              }
              else if(strcmp(str1,"Eb") == 0)
              {
                   printf("D# %s ",str2);
              }
              else if(strcmp(str1,"F#") == 0)
              {
                   printf("Gb %s ",str2);
              }
              else if(strcmp(str1,"Gb") == 0)
              {
                   printf("F# %s ",str2);    
              }
              else if(strcmp(str1,"G#") == 0)
              {
                   printf("Ab %s ",str2);
              }
              else if(strcmp(str1,"Ab") == 0)
              {
                   printf("G# %s ",str2);
              }
              else
              {
                   printf("UNIQUE ");
              }
         }
        
         return 0;
    }
     
     
    注意:
    1.英语真心没看懂,英语水平真是渣呀。
    2.有更优秀的代码,感觉真心不错:
     
    找到了转换的关系,一切交由代码决定。

    #include<iostream>
    #include<string>
    using namespace std;
    string trans(string a){
         string b="";
         if(a[1]=='#'){
              b+=char((a[0]-'A'+1)%7+'A');
              b+='b';
         }else{
              b+=char((a[0]-'A'+6)%7+'A');
              b+='#';
         }
         return b;
    }
    int main(){
         string a,b;
         for(int t=1; cin>>a>>b; t++){
              cout<<"Case "<<t<<": ";
              if(a.length()==1)
                   cout<<"UNIQUE"<<endl;
              else
                   cout<<trans(a)<<" "<<b<<endl;
         }
         return 0;
    }
             
  • 相关阅读:
    Object中的线程等待和Condition
    synchronized锁和Lock锁
    手写二叉排序树(二叉查找树、二叉搜索树)
    JDK源码之ArrayList-Iterator
    JDK源码之ArrayList
    Integer&int,自动装箱&自动拆箱
    学习Zookeeper第一课
    Thumbnailator处理图片
    线程的停止和中断
    BigInteger和BigDecimal
  • 原文地址:https://www.cnblogs.com/sharpfeng/p/5141193.html
Copyright © 2020-2023  润新知