• poj 1330 , LCA, 乱搞


    K - Nearest Common Ancestors
    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

    Description

    A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


    In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

    For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

    Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

    Output

    Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

    Sample Input

    2
    16
    1 14
    8 5
    10 16
    5 9
    4 6
    8 4
    4 10
    1 13
    6 15
    10 11
    6 7
    10 2
    16 3
    8 1
    16 12
    16 7
    5
    2 3
    3 4
    3 1
    1 5
    3 5
    

    Sample Output

    4
    3
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    //另一种方法,记下所有点所在的层数。。。,再逐“父亲”比较
    int p[10008],pa[10008],pb[10008];
    
    void getFa(int x,int &n,int *f){
        n=0;
        f[n++]=x;
        while(p[x]){//直到找到根节点
            x=p[x];
            f[n++]=x;
        }
    }
    
    int binarySearch(int e,int *a,int n){
        int l=0,h=n-1,mid;
        while(l<=h){
            mid=(l+h)/2;
            if(a[mid]==e)return e;
            if(a[mid]>e) h=mid-1;
            else l=mid+1;
        }
        return -1;
    }
    
    int findMCA(int a,int b,int na,int nb){
        if(a==b) return a;
        if(na>nb){
            sort(pa,pa+na);
            for(int i=0;i<nb;i++){
                int tmp=binarySearch(pb[i],pa,na);
                if(tmp!=-1)return tmp;
            }
        }
        else{
            sort(pb,pb+nb);
            for(int i=0;i<na;i++){
                int tmp=binarySearch(pa[i],pb,nb);
                if(tmp!=-1)return tmp;
            }
        }
    }
    
    int main(){
        int n,t,pat,son;
        int a,b,na,nb;
        cin>>t;
        while(t--){
            cin>>n;
            memset(p+1,0,sizeof(int)*n);
            for(int i=1;i<n;i++){
                cin>>pat>>son;
                p[son]=pat;
            }
            cin>>a>>b;
            getFa(a,na,pa);
            getFa(b,nb,pb);
            cout<<findMCA(a,b,na,nb)<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    21. Fluentd输出插件:rewrite_tag_filter用法详解
    19. Fluentd输入插件:in_http用法详解
    18. Fluentd输出插件:out_stdout用法详解
    17. Fluentd输出插件:out_copy用法详解
    15. Fluentd输入插件:in_tail用法详解
    14. Fluentd输出插件:out_forward用法详解
    13. Fluentd输出插件:in_forward用法详解
    16. 综合使用tail、forward、copy和stdout
    20. 使用Fluentd发送告警邮件
    使用Fluentd进行简单流处理
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3413050.html
Copyright © 2020-2023  润新知