• hdu 5769 Substring 后缀数组


    Substring

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5769

    Description

    ?? is practicing his program skill, and now he is given a string, he has to calculate the total number of its distinct substrings.
    But ?? thinks that is too easy, he wants to make this problem more interesting.
    ?? likes a character X very much, so he wants to know the number of distinct substrings which contains at least one X.
    However, ?? is unable to solve it, please help him.

    Input

    The first line of the input gives the number of test cases T;T test cases follow.
    Each test case is consist of 2 lines:
    First line is a character X, and second line is a string S.
    X is a lowercase letter, and S contains lowercase letters(‘a’-‘z’) only.

    T<=30
    1<=|S|<=10^5
    The sum of |S| in all the test cases is no more than 700,000.

    Output

    For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the answer you get for that case.

    Sample Input

    2
    a
    abc
    b
    bbb

    Sample Output

    Case #1: 3
    Case #2: 3

    Hint
    In first case, all distinct substrings containing at least one a: a, ab, abc.
    In second case, all distinct substrings containing at least one b: b, bb, bbb.

    Hint

    题意

    给你个字符串,问你至少含有一个x字符的子串数量有多少个

    题解:

    处理出后缀数组中的sa[]数组和height[]数组。在不考虑包含字符X的情况下,不同子串的个数为(sum_{1}^{length} length-(sa[i]+height[i]))

    如果要求字符X,只需要记录距离sa[i]最近的字符X的位置(用nxt[sa[i]]表示)即可,个数为(sum_{1}^{length} length-max(nxt[sa[i]],sa[i]+height[i]))

    代码

    #include <bits/stdc++.h>
    
    using namespace std;
    
    const int maxn=100100;
    const int inf=0x3f3f3f3f;
    int wa[maxn],wb[maxn],wn[maxn],wv[maxn];
    int rk[maxn],height[maxn],sa[maxn],r[maxn],n;
    int last[maxn];
    char str[maxn],ss[5];
    
    int cmp(int *r,int a,int b,int l)
    {
        return (r[a]==r[b])&&(r[a+l]==r[b+l]);
    }
    void da(int *r,int *sa,int n,int m)
    {
        int i,j,p,*x=wa,*y=wb,*t;
        for(i=0;i<m;i++) wn[i]=0;
        for(i=0;i<n;i++) wn[x[i]=r[i]]++;
        for(i=1;i<m;i++) wn[i]+=wn[i-1];
        for(i=n-1;i>=0;i--) sa[--wn[x[i]]]=i;
        for(j=1,p=1;p<n;j*=2,m=p)
        {
            for(p=0,i=n-j;i<n;i++) y[p++]=i;
            for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
            for(i=0;i<n;i++) wv[i]=x[y[i]];
            for(i=0;i<m;i++) wn[i]=0;
            for(i=0;i<n;i++) wn[wv[i]]++;
            for(i=1;i<m;i++) wn[i]+=wn[i-1];
            for(i=n-1;i>=0;i--) sa[--wn[wv[i]]]=y[i];
            for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
                x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
        }
    }
    void calheight(int *r,int *sa,int n)
    {
        int i,j,k=0;
        for(i=1;i<=n;i++) rk[sa[i]]=i;
        for(i=0;i<n;height[rk[i++]]=k )
        for(k?k--:0,j=sa[rk[i]-1];r[i+k]==r[j+k];k++);
    }
    
    int main()
    {
        //freopen("1.in","r",stdin);
        int T;
        scanf("%d",&T);
        for(int o=1;o<=T;o++)
        {
            scanf("%s",ss);
            scanf("%s",str);
            int n=strlen(str),now=n;
            for(int i=n-1;i>=0;i--)
            {
                if(str[i]==ss[0]) now=i;
                last[i]=now;
            }
            for(int i=0;i<n;i++)
                r[i]=str[i];
            r[n]=0;
            da(r,sa,n+1,256);
            calheight(r,sa,n);
            long long ans=0;
            for(int i=1;i<=n;i++)
            {
                int tmp=max(last[sa[i]]-sa[i],height[i]);
                ans+=1LL*max(0,n-sa[i]-tmp);
            }
            printf("Case #%d: ",o);
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Java vs C++ 基础异同比较
    2. 数组
    1. 数据结构概述
    动态规划专题:LeetCode 完全平方数
    动态规划专题:LeetCode 乘积最大子数组
    动态规划专题:LeetCode连续数列
    动态规划专题:LeetCode 按摩师
    3. 无重复字符的最长子串
    字典树(前缀树/后缀树)
    10. 排序算法思想概述及总结(精华)
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5715917.html
Copyright © 2020-2023  润新知