• HDOJ1022(模拟栈)


    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 31758    Accepted Submission(s): 11976


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
    3 123 321
    3 123 312
     
    Sample Output
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    #include <iostream>
    #include <stack>
    #include <string>
    using namespace std;
    const int MAXN=20;
    char o1[MAXN],o2[MAXN];
    int n;
    string op[MAXN];
    int top;
    int main()
    {
        while(cin>>n)
        {
            cin>>o1>>o2;
            top=0;
            stack<char> st;
            for(int i=0,j=0,len=strlen(o1);i<len;i++)
            {
                st.push(o1[i]);
                op[top++]="in";
                while(st.top()==o2[j])
                {
                    st.pop();
                    j++;
                    op[top++]="out";
                    if(st.empty())    break;
                }
            }
            if(st.empty())
            {
                cout<<"Yes."<<endl;
                for(int i=0;i<top;i++)
                {
                    cout<<op[i]<<endl;
                }
            }
            else    cout<<"No."<<endl;
            cout<<"FINISH"<<endl;
        }
        
        return 0;
    }
  • 相关阅读:
    《把时间当作朋友》读书笔记
    Oracle&SQLServer中实现跨库查询
    Android学习——界面互调2
    《IT不再重要》读后感
    Android学习——数据存储
    Android学习——编写菜单
    Android学习——后台程序
    Android学习——写个小实例
    Android学习——界面编程!
    深入理解JavaScript系列(42):设计模式之原型模式
  • 原文地址:https://www.cnblogs.com/program-ccc/p/4691725.html
Copyright © 2020-2023  润新知