• P2854 [USACO06DEC]牛的过山车Cow Roller Coaster


    题目描述

    The cows are building a roller coaster! They want your help to design as fun a roller coaster as possible, while keeping to the budget.

    The roller coaster will be built on a long linear stretch of land of length L (1 ≤ L ≤ 1,000). The roller coaster comprises a collection of some of the N (1 ≤ N ≤ 10,000) different interchangable components. Each component i has a fixed length Wi (1 ≤ Wi ≤ L). Due to varying terrain, each component i can be only built starting at location Xi (0 ≤ Xi ≤ L - Wi). The cows want to string together various roller coaster components starting at 0 and ending at L so that the end of each component (except the last) is the start of the next component.

    Each component i has a "fun rating" Fi (1 ≤ Fi ≤ 1,000,000) and a cost Ci (1 ≤ Ci ≤ 1000). The total fun of the roller coster is the sum of the fun from each component used; the total cost is likewise the sum of the costs of each component used. The cows' total budget is B (1 ≤ B ≤ 1000). Help the cows determine the most fun roller coaster that they can build with their budget.

    奶牛们正打算造一条过山车轨道.她们希望你帮忙,找出最有趣,但又符合预算 的方案. 过山车的轨道由若干钢轨首尾相连,由x=0处一直延伸到X=L(1≤L≤1000)处.现有N(1≤N≤10000)根钢轨,每根钢轨的起点 Xi(0≤Xi≤L- Wi),长度wi(l≤Wi≤L),有趣指数Fi(1≤Fi≤1000000),成本Ci(l≤Ci≤1000)均己知.请确定一 种最优方案,使得选用的钢轨的有趣指数之和最大,同时成本之和不超过B(1≤B≤1000).

    输入输出格式

    输入格式:

    Line 1: Three space-separated integers: L, N and B.

    Lines 2..N+1: Line i+1 contains four space-separated integers, respectively: Xi, Wi, Fi, and Ci.

    输出格式:

    Line 1: A single integer that is the maximum fun value that a roller-coaster can have while staying within the budget and meeting all the other constraints. If it is not possible to build a roller-coaster within budget, output -1.

    输入输出样例

    输入样例#1: 复制
    5 6 10
    0 2 20 6
    2 3 5 6
    0 1 2 1
    1 1 1 3
    1 2 5 4
    3 2 10 2
    输出样例#1: 复制
    17

    说明

    Taking the 3rd, 5th and 6th components gives a connected roller-coaster with fun value 17 and cost 7. Taking the first two components would give a more fun roller-coaster (25) but would be over budget.

    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define inf 2147483647
    const ll INF = 0x3f3f3f3f3f3f3f3fll;
    #define ri register int
    template <class T> inline T min(T a, T b, T c)
    {
        return min(min(a, b), c);
    }
    template <class T> inline T max(T a, T b, T c)
    {
        return max(max(a, b), c);
    }
    template <class T> inline T min(T a, T b, T c, T d)
    {
        return min(min(a, b), min(c, d));
    }
    template <class T> inline T max(T a, T b, T c, T d)
    {
        return max(max(a, b), max(c, d));
    }
    #define pi acos(-1)
    #define me(x, y) memset(x, y, sizeof(x));
    #define For(i, a, b) for (int i = a; i <= b; i++)
    #define FFor(i, a, b) for (int i = a; i >= b; i--)
    #define mp make_pair
    #define pb push_back
    const int maxn = 100005;
    // name*******************************
    int f[1005][1005];
    int L,n,B;
    struct node
    {
        int x,w,f,c;
    } a[10005];
    int ans=-1;
    // function******************************
    bool cmp(node a,node b)
    {
        return a.x<b.x;
    }
    
    //***************************************
    int main()
    {
        cin>>L>>n>>B;
        For(i,1,n)
        {
            cin>>a[i].x>>a[i].w>>a[i].f>>a[i].c;
        }
        me(f,-1);
        sort(a+1,a+1+n,cmp);
        f[0][0]=0;
        For(i,1,n)
        {
            int u=a[i].x;
            int v=a[i].x+a[i].w;
            FFor(j,B,a[i].c)
            {
                if(f[u][j-a[i].c]!=-1)
                    f[v][j]=max(f[v][j],f[u][j-a[i].c]+a[i].f);
            }
        }
        For(i,0,B)
        ans=max(ans,f[L][i]);
        cout<<ans;
    
        return 0;
    }
  • 相关阅读:
    翻译MDN里js的一些方法属性
    ajax相关
    我的面试错题
    写代码通用思路
    工厂模式
    cookie & session
    X-UA-Compatible设置IE浏览器兼容模式
    [转]IE6/IE7/IE8/IE9中tbody的innerHTML不能赋值的完美解决方案
    EasyUseCase 一款脑图转化 Excel 测试用例工具 (1.2 版本升级)
    XMind2TestCase:一个高效测试用例设计的解决方案!
  • 原文地址:https://www.cnblogs.com/planche/p/8659568.html
Copyright © 2020-2023  润新知