• BZOJ 3831: [Poi2014]Little Bird【动态规划】


    Description

    In the Byteotian Line Forest there are   trees in a row. On top of the first one, there is a little bird who would like to fly over to the top of the last tree. Being in fact very little, the bird might lack the strength to fly there without any stop. If the bird is sitting on top of the tree no.  , then in a single flight leg it can fly to any of the trees no.i+1,i+2…I+K, and then has to rest afterward.

    Moreover, flying up is far harder to flying down. A flight leg is tiresome if it ends in a tree at least as high as the one where is started. Otherwise the flight leg is not tiresome.

    The goal is to select the trees on which the little bird will land so that the overall flight is least tiresome, i.e., it has the minimum number of tiresome legs. We note that birds are social creatures, and our bird has a few bird-friends who would also like to get from the first tree to the last one. The stamina of all the birds varies, so the bird's friends may have different values of the parameter  . Help all the birds, little and big!

    有一排n棵树,第i棵树的高度是Di。

    MHY要从第一棵树到第n棵树去找他的妹子玩。

    如果MHY在第i棵树,那么他可以跳到第i+1,i+2,...,i+k棵树。

    如果MHY跳到一棵不矮于当前树的树,那么他的劳累值会+1,否则不会。

    为了有体力和妹子玩,MHY要最小化劳累值。

    Input

    There is a single integer N(2<=N<=1 000 000) in the first line of the standard input: the number of trees in the Byteotian Line Forest. The second line of input holds   integers D1,D2…Dn(1<=Di<=10^9) separated by single spaces: Di is the height of the i-th tree.

    The third line of the input holds a single integer Q(1<=Q<=25): the number of birds whose flights need to be planned. The following Q lines describe these birds: in the i-th of these lines, there is an integer Ki(1<=Ki<=N-1) specifying the i-th bird's stamina. In other words, the maximum number of trees that the i-th bird can pass before it has to rest is Ki-1.

    Output

    Your program should print exactly Q lines to the standard output. In the I-th line, it should specify the minimum number of tiresome flight legs of the i-th bird.

    Sample Input

    9
    4 6 3 6 3 7 2 6 5
    2
    2
    5

    Sample Output

    2
    1

    HINT

    Explanation: The first bird may stop at the trees no. 1, 3, 5, 7, 8, 9. Its tiresome flight legs will be the one from the 3-rd tree to the 5-th one and from the 7-th to the 8-th.

    思路我太弱了。。。。这么水的题都想了这么久。。。。。dp方程应该很好想的,顺手就敲完了了,然后。。。TLE

    #include<cstdio>

    #include<iostream>

    #include<cstring>

    #define maxn 1000009

    #define inf 0x3f3f3f3f

    using namespace std;

    int a[maxn],dp[maxn];

    int main()

    {

            int n,q,k;

            scanf("%d",&n);

            for(int i=1;i<=n;i++)scanf("%d",&a[i]);

            scanf("%d",&q);

            for(int i=1;i<=n;i++)

            {

                    scanf("%d",&k);

                    memset(dp,0x3f,sizeof(dp));

                    dp[1]=0;

                    for(int i=2;i<=n;i++)

                    {

                            for(int j=max(0,i-k);j<=i;j++)

                            {

                                    if(a[j]<a[i])dp[i]=min(dp[i],dp[j]);

                                    else dp[i]=min(dp[i],dp[j]+1);

                            }

                           // printf("%d %d ",i,dp[i]);

                    }

                    printf("%d ",dp[n]);

            }

            return 0;

    }

    想了想这是n^2的dp,好像可以用单调队列优化的样子,以单调队列中以dp[i]为第一关键字,第i棵树的高度为第二关键字,然后就a了,想想也挺显然的

    AC代码:

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<map>
    #define maxn 1000009
    #define inf 0x3f3f3f3f
    using namespace std;
    int a[maxn],dp[maxn],que[maxn];
    int main()
    {
            int n,q,k;scanf("%d",&n);
            for(int i=1;i<=n;i++)scanf("%d",&a[i]);
            scanf("%d",&q);
            for(int i=1;i<=q;i++)
            {
                    scanf("%d",&k);
                    int l=0,r=0;
                    que[r]=1;dp[1]=0;
                    for(int i=2;i<=n;i++)
                    {
                            while(l<=r&&(que[l]+k<i))l++;
                            if(a[que[l]]>a[i])dp[i]=dp[que[l]];else dp[i]=dp[que[l]]+1;
                            while(l<=r&&(dp[que[r]]>dp[i]||(dp[que[r]]==dp[i]&&a[que[r]]<a[i])))r--;
                            que[++r]=i;
                    }
                    printf("%d ",dp[n]);
            }
            return 0;
    }

  • 相关阅读:
    webpack学习笔记--配置resolve
    常用 Git 命令清单
    彻底解决Webpack打包慢的问题
    vue-cli3安装遇到的问题,卸载不掉旧版本,导致更新不了
    在5分钟内搭建企业内部私有npm仓库
    package.json中你还不清楚的browser,module,main 字段优先级
    细说 peerDependencies
    对peerDependencies的理解
    [转载]罗技Usb Receiver在Win7 64位系统中驱动安装方法
    波峰波谷的判断
  • 原文地址:https://www.cnblogs.com/philippica/p/4206938.html
Copyright © 2020-2023  润新知