• HDU 1556 Color the ball(树状数组)


    Color the ball

    Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 23618 Accepted Submission(s): 11479

    Problem Description
    N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

    Input
    每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
    当N = 0,输入结束。

    Output
    每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

    Sample Input
    3
    1 1
    2 2
    3 3
    3
    1 1
    1 2
    1 3
    0

    Sample Output
    1 1 1
    3 2 1

    题意

    题解:

    树状数组很容易求解。更新的时候在左端点+1,右端点的下一个-1。具体的树状数组的实现请自行查找,这里仅贴出代码。(因为懒~~)

    #include<iostream>
    #include<cstring>
    using namespace std;
    const int maxn=1e5+5;
    int BIT[maxn];
    int N;
    int lowbit(int i)
    {
    	return i&(-i);
    }
    int sum(int i)
    {
    	int s=0;
    	while(i>0)
    	{
    		s+=BIT[i];
    		i-=lowbit(i);
    	}
    	return s;
    }
    void add(int i,int x)
    {
    	while(i<=N)
    	{
    		BIT[i]+=x;
    		i+=lowbit(i);
    	}
    }
    int main()
    {
    	while(cin>>N&&N)
    	{
    		memset(BIT,0,sizeof(BIT));
    		for(int i=0;i<N;i++)
    		{
    			int a,b;
    			cin>>a>>b;
    			add(a,1);
    			add(b+1,-1);
    		}
    		for(int i=1;i<=N;i++)
    			if(i==N)
    				cout<<sum(i)<<endl;
    			else
    				cout<<sum(i)<<" ";
    
    	}
    }
  • 相关阅读:
    20170228 Z_po_send_email
    MRP 流程
    MRP 中的数据元素
    笔记:使用 Protel 99 SE 改一块车充 PCB
    PCB 锣板和半孔工艺的差别
    笔记:LIR2032 电池充电记录
    笔记:开源协议 Apache 2 和 GPL 兼容
    FastAdmin 在 CRUD 时出现 exec() has been disabled for security reasons 怎么办?
    FastAdmin 学习线路 (2018-09-09 增加 Layer 组件)
    记录一下变压器的焊盘问题
  • 原文地址:https://www.cnblogs.com/orion7/p/7629984.html
Copyright © 2020-2023  润新知