• 01背包(第k优解)


    Bone Collector II

    Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7165    Accepted Submission(s): 3802


    Problem Description
    The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

    Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

    Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

    If the total number of different values is less than K,just ouput 0.
     
    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the K-th maximum of the total value (this number will be less than 231).
     
    Sample Input
    3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
     
    Sample Output
    12 2 0
     
    Author
    teddy
     
    Source
     
    思路:把放第i个物品看成序列a,不放序列看成序列b,合并依次组成k解。相当于把2的n次方情况排序取前30种。
     
    //#include <bits/stdc++.h>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <algorithm>
    #include <iostream>
    #include <algorithm>
    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <cstring>
    #include <stdio.h>
    #include <queue>
    #include <stack>;
    #include <map>
    #include <set>
    #include <string.h>
    #include <vector>
    #define ME(x , y) memset(x , y , sizeof(x))
    #define SF(n) scanf("%d" , &n)
    #define rep(i , n) for(int i = 0 ; i < n ; i ++)
    #define INF  0x3f3f3f3f
    #define mod 1000000007
    #define PI acos(-1)
    using namespace std;
    typedef long long ll ;
    int dp[1009][35];
    int val[1009] , vol[1009];
    
    int main()
    {
        int t ;
        scanf("%d" , &t);
        while(t--)
        {
            int n , v , kk , a[35] , b[35];
            scanf("%d%d%d" , &n , &v , &kk);
            memset(dp , 0 , sizeof(dp));
            for(int i = 1 ; i <= n ; i++)
            {
                scanf("%d" , &val[i]);
            }
            for(int i = 1 ; i <= n ; i++)
            {
                scanf("%d" , &vol[i]);
            }
            for(int i = 1 ; i <= n ; i++)
            {
                for(int j = v ; j >= vol[i] ; j--)
                {
                    for(int k = 1 ; k <= kk ; k++)//将所有解存起来
                    {
                        a[k] = dp[j][k];
                        b[k] = dp[j-vol[i]][k] + val[i] ;
                    }
                    // 对所有解进行排序
                    a[kk+1] = -1 ;
                    b[kk+1] = -1 ;
                    int k = 1 ;
                    int x = 1, y = 1 ;
                    while(k <= kk && (a[x] != -1 || b[y] != -1))
                    {
                        if(a[x] > b[y])
                        {
                            dp[j][k] = a[x];
                            x++ ;
                        }
                        else
                        {
                            dp[j][k] = b[y];
                            y++;
                        }
                        if(dp[j][k] != dp[j][k-1]) k++ ;
                    }
                }
            }
            cout << dp[v][kk] << endl ;
    
        }
    
        return 0;
    }
  • 相关阅读:
    第四周作业
    第三周作业
    第二周作业
    7-1,求最大值及下标值
    7-1.查找整数
    打印沙漏
    赚了还是亏了
    秋末学期总结
    机器学习小知识
    python 小知识
  • 原文地址:https://www.cnblogs.com/nonames/p/11673877.html
Copyright © 2020-2023  润新知