• 【PAT甲级】1092 To Buy or Not to Buy (20分):哈希


    题目:https://pintia.cn/problem-sets/994805342720868352/problems/994805374509498368

    1092 To Buy or Not to Buy (20分)

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

    figbuy.jpg

    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY
    
          
        
    

    Sample Output 1:

    Yes 8
    
          
        
    

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY
    
          
        
    

    Sample Output 2:

    No 2
    

    注意

    • 谨记一句话“所有变量使用前都要初始化赋值。

    经常碰到因为没初始化导致运算结果出错的情况,在C++中局部变量使用前一定要手动初始化,全局变量会默认初始化,但记来记去容易搞混,全部初始化吧。


    代码

    #include<iostream>
    
    using namespace std;
    
    int main() {
    	string s1,s2;//店主、Eva的字符串
    	int time[256];//数组记录 字符出现次数
    	int result=0;//缺珠子的个数
    	cin>>s1;
    	getchar();
    	cin>>s2;
    
    	fill(time,time+256,0);
    	for(int i=0; i<s1.length(); i++) {
    		time[s1[i]]++;
    	}
    	for(int i=0; i<s2.length(); i++) {
    		if(time[s2[i]]>0) {
    			time[s2[i]]--;//珠子给Eva
    		} else { //缺珠子
    			result++;
    		}
    	}
    
    	if(result!=0) {//缺珠子
    		cout<<"No "<<result;
    	} else //不缺珠子 ,输出要多买珠子的数量
    		cout<<"Yes "<<s1.length()-s2.length();
    
    
    
    	return 0;
    }
    
  • 相关阅读:
    greenlet和gevent模块的区别?
    Python整型int、浮点float常用方法
    jquery的相关应用
    mongoDB在java上面的应用
    SpringAOP的两种实现方式
    svn 服务器搭建 (Linux)
    maven的两种打包方式
    MongoDB 安装与配置
    springmvc拦截器配置
    Linux下安装mysql
  • 原文地址:https://www.cnblogs.com/musecho/p/12287031.html
Copyright © 2020-2023  润新知