• POJ 2996 Help Me with the Game 模拟


    Help Me with the Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3344   Accepted: 2145

    Description

    Your task is to read a picture of a chessboard position and print it in the chess notation.

    Input

    The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

    Output

    The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

    The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

    The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

    Sample Input

    +---+---+---+---+---+---+---+---+
    |.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
    +---+---+---+---+---+---+---+---+
    |:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
    +---+---+---+---+---+---+---+---+
    |...|:::|.n.|:::|...|:::|...|:p:|
    +---+---+---+---+---+---+---+---+
    |:::|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |...|:::|...|:::|.P.|:::|...|:::|
    +---+---+---+---+---+---+---+---+
    |:P:|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
    +---+---+---+---+---+---+---+---+
    |:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
    +---+---+---+---+---+---+---+---+
    

    Sample Output

    White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
    Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6


    #include<iostream>
    using namespace std;
    
    #define  WHILT 1
    #define  BLACK 0
    char str[10][10],ch[]="KQRBNP";
    
    void hansi(int x,int &y,char c)
    {
    	char c1=c;
    	int i,j;
    	if(x==BLACK)
    		c += 32;
    	if(x==BLACK)
    	{
    		for(i=1;i<=8;i++)
    		{
    			for(j=1;j<=8;j++)
    			{
    				if(str[i][j]==c)
    				{
    					if(y)  y=0;
    					else  cout<<",";
    					if(c!='p' && c!='P')
    						cout<<c1;
    					printf("%c%d",j+'a'-1,9-i);
    				}
    			}
    		}
    	}
    	else
    	{
    		for(i=8;i>=1;i--)
    		{
    			for(j=1;j<=8;j++)
    			{
    				if(str[i][j]==c)
    				{
    					if(y)  y=0;
    					else  cout<<",";
    					if(c!='p' && c!='P')
    						cout<<c1;
    					printf("%c%d",j+'a'-1,9-i);
    				}
    			}
    		}
    	}
    }
    
    void hanyi()
    {
        scanf("+---+---+---+---+---+---+---+---+");
        getchar();
    }
    
    char haner()
    {
        char a,b,c;
        scanf("|%c%c%c",&a,&b,&c);
        return b;
    }
    
    void hansan(int cur)
    {
    	if(cur==WHILT)
    		cout<<"White: ";
    	else
    		cout<<"Black: ";
    	int flag=1;
    	for(int i=0;i<6;i++)
    		hansi(cur,flag,ch[i]);
    	cout<<endl;
    }
    
    int main()
    {
        int i,j;
        for(i=1;i<=8;i++)
        {
            hanyi();
            for(j=1;j<=8;j++)
                str[i][j]=haner();
            getchar();
            getchar();
        }
        hanyi();
        hansan(WHILT);
    	hansan(BLACK);
        return 0;
    }


  • 相关阅读:
    python 将png图片格式转换生成gif动画
    JetBrains系IDE的设置Pycharm PHPStorm
    Nginx 静态页面POST 请求提示405 Not Allowed
    安装SSL证书 and 根域名跳转www域名
    Linux 安装qt5-designer并集成到Pycharm
    Deepin 自动挂载win NTFS磁盘
    Nginx+DNS负载均衡实现
    swoole websocket服务推送
    Linux版 php5.4 升级php7
    百度 Javascript开发 API
  • 原文地址:https://www.cnblogs.com/mthoutai/p/7084444.html
Copyright © 2020-2023  润新知