• 1020 月饼


    月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

    注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

    输入格式:

    每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

    输出格式:

    对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

    输入样例:

    3 20
    18 15 10
    75 72 45
    

    输出样例:

    94.50

    注意: 单位是万吨, 也就是说可以是小数, 故库存量用double这种数据类型(所以结构体中定义double stock; // 该类商品的总量 ) (就因为数据类型不对, 卡了一个小时......)
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    struct Good
    {
    	double stock;		// 该类商品的总量 
    	double sale;	// 该类商品的总价 
    	double price;	// 该类商品的单价 
    };
    
    bool cmp(const Good a, const Good b)
    {
    	return a.price > b.price;
    }
    
    int main()
    {
    	int n, d;
    	double profit = 0.0;
    	cin >> n >> d;
    	
    	Good good[n];	
    	for(int i = 0; i < n; ++ i)
    	{
    		cin >> good[i].stock;
    	}
    	for(int i = 0; i < n; ++ i)
    	{
    		cin >> good[i].sale;
    		good[i].price = good[i].sale / good[i].stock;
    	}
    	
    	sort(good, good + n, cmp);
    	
    	for(int i = 0; i < n; ++ i)
    	{
    		if(d >= good[i].stock)
    		{
    			profit += good[i].sale;
    			d = d - good[i].stock;
    		}
    		else
    		{
    			profit += good[i].price * d;
    			break;
    		}
    	}
    	
    	printf("%.2f", profit);
    	
    	return 0;
    } 
    

      

  • 相关阅读:
    flask 返回json数据
    flask 中文乱码
    flask 参数校验
    AOP集成防止连续多次点击问题
    关于横竖屏切换导致的Activity重建问题
    Flutter工程无法找到Android真机或Android模拟器
    Failed to find configured root that contains
    Unable to resolve dependency问题解决
    双重ScrollView,RecyclerView联动实例
    RecyclerView联动滑动失败
  • 原文地址:https://www.cnblogs.com/mjn1/p/10857293.html
Copyright © 2020-2023  润新知