• poj2105 IP Address(简单题)


    题目链接:http://poj.org/problem?id=2105

    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    欢迎光临天资小屋害羞害羞害羞害羞http://user.qzone.qq.com/593830943/main
    
    
    ----------------------------------------------------------------------------------------------------------------------------------------------------------


    Description

    Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are: 
    27   26  25  24  23   22  21  20 
    
    128 64  32  16  8   4   2   1 

    Input

    The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

    Output

    The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

    Sample Input

    4
    00000000000000000000000000000000 
    00000011100000001111111111111111 
    11001011100001001110010110000000 
    01010000000100000000000000000001 

    Sample Output

    0.0.0.0
    3.128.255.255
    203.132.229.128
    80.16.0.1

    题意:非常easy, 就是每一个案例给出一个32位的2进制数字串。 要求依照每8位转换为8进制输出(中间有‘.’)就可以!

    代码例如以下:

    #include <iostream>
    #include <cmath>
    using namespace std;
    int main()
    {
    	int N;
    	int i, j;
    	char s[117];
    	while(cin >> N)
    	{
    		while(N--)
    		{
    			cin>>s;
    			int ans[4], k = 7, l = 0;
    			int sum = 0;
    			for(i = 0; i < 32; i++)
    			{
    				sum +=(s[i]-'0')*pow(2.0,k);
    				k--;
    				if(i%8==7)
    				{
    					ans[l++] = sum;
    					sum = 0;
    					k = 7;
    				}
    			}
    			cout<<ans[0]<<'.'<<ans[1]<<'.'<<ans[2]<<'.'<<ans[3]<<endl;
    		}
    	}
    	return 0;
    }


  • 相关阅读:
    JUC回顾之-可重入的互斥锁ReentrantLock
    java基础知识回顾之java Thread类学习(十二)-- 线程中断
    mknod命令
    一个公益水塘引发的纠纷
    对cgic的理解——name选项
    linux的fwrite()使用方法,当前时间写入文本的程序
    /etc/resolv.conf文件详解
    关于函数strtok和strtok_r的使用要点和实现原理
    shell视频
    进程一些命令pstree,ps,pstack,top
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5334112.html
Copyright © 2020-2023  润新知