畅通工程再续
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11114 Accepted Submission(s): 3383
Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!
并查集
代码:
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int n,num;
double sum;
int father[210];
void make_set()
{
int i;
for(i=1; i<=n; i++)
father[i]=i;
}
int find_set(int x)
{
return x==father[x]?x:father[x]=find_set(father[x]);
}
struct node
{
int x,y;
} a[5100];
struct edg
{
int start,end;
double money;
}b[5100];
bool cmp(edg a,edg b)
{
return a. money<b. money;
}
void unon(int x,int y,double z)
{
x=find_set(x);
y=find_set(y);
if(x!=y)
{
sum+=z;
father[y]=x;
}
}
int main()
{
int i,j,t;
double dis;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
sum=0;
num=1;
make_set();
for(i=1; i<=n; i++)
scanf("%d%d",&a[i].x,&a[i].y);
for(i=1;i<=n;i++)
for(j=i+1;j<=n;j++)
{
dis=(double)sqrt((double)((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y)));
if(dis>=10&&dis<=1000)
{
b[num]. money=dis*100;
b[num].start=i;
b[num].end=j;
num++;
}
}
sort(b+1,b+num+1,cmp);
for(i=1; i<=num; i++)
{
unon(b[i].start,b[i].end,b[i]. money);
}
if(sum>0)
printf("%.1lf ",sum);
else
printf("oh! ");
}
}
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int n,num;
double sum;
int father[210];
void make_set()
{
int i;
for(i=1; i<=n; i++)
father[i]=i;
}
int find_set(int x)
{
return x==father[x]?x:father[x]=find_set(father[x]);
}
struct node
{
int x,y;
} a[5100];
struct edg
{
int start,end;
double money;
}b[5100];
bool cmp(edg a,edg b)
{
return a. money<b. money;
}
void unon(int x,int y,double z)
{
x=find_set(x);
y=find_set(y);
if(x!=y)
{
sum+=z;
father[y]=x;
}
}
int main()
{
int i,j,t;
double dis;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
sum=0;
num=1;
make_set();
for(i=1; i<=n; i++)
scanf("%d%d",&a[i].x,&a[i].y);
for(i=1;i<=n;i++)
for(j=i+1;j<=n;j++)
{
dis=(double)sqrt((double)((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y)));
if(dis>=10&&dis<=1000)
{
b[num]. money=dis*100;
b[num].start=i;
b[num].end=j;
num++;
}
}
sort(b+1,b+num+1,cmp);
for(i=1; i<=num; i++)
{
unon(b[i].start,b[i].end,b[i]. money);
}
if(sum>0)
printf("%.1lf ",sum);
else
printf("oh! ");
}
}