• hdu 1250


    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5445    Accepted Submission(s): 1820


    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
    F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
    Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646
    Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     
    #include<stdio.h>
    #include<string.h> 
    int a[8000][300];
    int main() 

        int i,j,n,num[8000];
        memset(a,0,sizeof(a));
        memset(num,0,sizeof(num));
        a[1][0]=a[2][0]=a[3][0]=a[4][0]=1; 
        num[1]=num[2]=num[3]=num[4]=1; 
        for(i=5;i<8000;i++)  //打表
        { 
            for(j=0;j<num[i-1];j++)  //num[]用来储存a[i][j]的位数
            { 
                a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]; 
                a[i][j+1]+=a[i][j]/100000000; 
                a[i][j]%=100000000; 
            } 
            num[i]=num[i-1]; 
            if(a[i][num[i]]!=0)
                num[i]++; 
        } 
        while(~scanf("%d",&n)) 
        { 
            if(n==0) 
            {
                printf("0 ");
                continue;
            } 
         printf("%d",a[n][num[n]-1]); 
            for(i=num[n]-2;i>=0;i--)
                printf("%08d",a[n][i]);  //位数不足8位的,在前边补充0
            printf(" "); 
        } 
        return 0; 
    }
  • 相关阅读:
    android权限大全
    Java反射经典实例
    SD卡的寄存器 SD总线协议 CRC算法
    ARM CortexM3 操作模式和特权级别
    使用 Printf via SWO/SWV 输出调试信息
    embOS实时操作系统 概览
    embOS实时操作系统 多任务调度
    android wifi hotspot
    Eclipse Java 智能提示
    ARM CortexM3 概览
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3268147.html
Copyright © 2020-2023  润新知