• A Bug


    A Bug

    Time Limit:   1000MS       Memory Limit:   65535KB
    Submissions:   231       Accepted:   84
    Description

    Background
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
    Problem
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!
    Scenario #2:
    No suspicious bugs found!


    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <stdlib.h>
    using namespace std;
    const int MAX = 10000;
    int father[MAX];
    int find(int x)
    {
        return x==father[x]?x:find(father[x]);
    }
    bool unionsearch(int x,int y)
    {
        int fx = find(x);
        int fy = find(y);
        if(fx==fy)
        {
            return false;
        }
        else
        {
            father[fy] = fx;
            return true;
        }
    }
    int main()
    {
        int num;
        scanf("%d",&num);
        int z=1;
        while(z<=num)
        {
            memset(father,0,sizeof(father));
            int n,m;
            scanf("%d %d",&n,&m);
            for(int i=1; i<=n; i++)
                father[i] = i;
            bool flag =false;
            for(int i= 1; i<=m; i++)
            {
                int a,b;
                scanf("%d %d",&a,&b);
                if(unionsearch(a,b))
                {
                }
                else
                {
                    flag = true;
                }
            }
            if(!flag)
                printf("Scenario #%d:
    No suspicious bugs found!
    ",z);
            else
                printf("Scenario #%d:
    Suspicious bugs found!
    ",z);
                z++;
        }
        return 0;
    }
  • 相关阅读:
    [LOJ 6436][PKUSC2018] 神仙的游戏
    [BZOJ 2653] middle
    [WC2018] 州区划分
    [BZOJ 4556][Tjoi2016&Heoi2016]字符串
    [BZOJ 3514]Codechef MARCH14 GERALD07加强版 (CHEF AND GRAPH QUERIES)
    [BZOJ 4573][ZJOI 2016]大♂森林
    Problem 2322. -- [BeiJing2011]梦想封印
    [BZOJ 2555] SubString
    [日常] NOIWC2019 冬眠记
    [BZOJ 4036][HAOI2015]按位或
  • 原文地址:https://www.cnblogs.com/locojyw/p/3715241.html
Copyright © 2020-2023  润新知