Time Limit: 1000MS |
Memory Limit: 65535KB |
Submissions: 231 |
Accepted: 84 |
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!
Scenario #2:
No suspicious bugs found!
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
const int MAX = 10000;
int father[MAX];
int find(int x)
{
return x==father[x]?x:find(father[x]);
}
bool unionsearch(int x,int y)
{
int fx = find(x);
int fy = find(y);
if(fx==fy)
{
return false;
}
else
{
father[fy] = fx;
return true;
}
}
int main()
{
int num;
scanf("%d",&num);
int z=1;
while(z<=num)
{
memset(father,0,sizeof(father));
int n,m;
scanf("%d %d",&n,&m);
for(int i=1; i<=n; i++)
father[i] = i;
bool flag =false;
for(int i= 1; i<=m; i++)
{
int a,b;
scanf("%d %d",&a,&b);
if(unionsearch(a,b))
{
}
else
{
flag = true;
}
}
if(!flag)
printf("Scenario #%d:
No suspicious bugs found!
",z);
else
printf("Scenario #%d:
Suspicious bugs found!
",z);
z++;
}
return 0;
}