• hdu 1250(大整数)


    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10430    Accepted Submission(s): 3447


    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
    F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
    Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     
    2005位的数大概在7100左右
    import java.math.BigInteger;
    import java.util.Scanner;
    
    
     
    public class Main {
        
        public static void main(String[] args) {
            BigInteger [] b = new BigInteger[7200];
            b[1]=b[2]=b[3]=b[4]= BigInteger.valueOf(1);
            int len = 0;
            for(int i=5;i<7200;i++){
                b[i] = b[i-1].add(b[i-2]).add(b[i-3]).add(b[i-4]);
            }
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n = sc.nextInt();
                System.out.println(b[n]);
            }
        }
    }
  • 相关阅读:
    关于Service所需要知道的大部分...
    GCN
    static变量(函数)和普通变量(函数)的区别
    FastGCN论文总结及实现(Tensorflow2.0)
    求相关系数矩阵
    K-means之亚洲杯
    归一化
    多指标综合评价方法汇总
    数据挖掘
    mat函数
  • 原文地址:https://www.cnblogs.com/liyinggang/p/5572092.html
Copyright © 2020-2023  润新知