• HDU 4118 Holiday's Accommodation


    Holiday's Accommodation

    Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 200000/200000 K (Java/Others)
    Total Submission(s): 2009    Accepted Submission(s): 558


    Problem Description
    Nowadays, people have many ways to save money on accommodation when they are on vacation.
    One of these ways is exchanging houses with other people.
    Here is a group of N people who want to travel around the world. They live in different cities, so they can travel to some other people's city and use someone's house temporary. Now they want to make a plan that choose a destination for each person. There are 2 rules should be satisfied:
    1. All the people should go to one of the other people's city.
    2. Two of them never go to the same city, because they are not willing to share a house.
    They want to maximize the sum of all people's travel distance. The travel distance of a person is the distance between the city he lives in and the city he travels to. These N cities have N - 1 highways connecting them. The travelers always choose the shortest path when traveling.
    Given the highways' information, it is your job to find the best plan, that maximum the total travel distance of all people.
     
    Input
    The first line of input contains one integer T(1 <= T <= 10), indicating the number of test cases.
    Each test case contains several lines.
    The first line contains an integer N(2 <= N <= 105), representing the number of cities.
    Then the followingN-1 lines each contains three integersX, Y,Z(1 <= X, Y <= N, 1 <= Z <= 106), means that there is a highway between city X and city Y , and length of that highway.
    You can assume all the cities are connected and the highways are bi-directional.
     
    Output
    For each test case in the input, print one line: "Case #X: Y", where X is the test case number (starting with 1) and Y represents the largest total travel distance of all people.
     
    Sample Input
    2 4 1 2 3 2 3 2 4 3 2 6 1 2 3 2 3 4 2 4 1 4 5 8 5 6 5
     
    Sample Output
    Case #1: 18 Case #2: 62
     
    Source
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stdio.h>
    #include <string.h>
    #include <vector>
    #include <queue>
    #include <set>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <math.h>
    #define Max(a,b) ((a)>(b)?(a):(b))
    #define Min(a,b) ((a)<(b)?(a):(b))
    #pragma comment(linker, "/STACK:10240000000000,10240000000000")
    using namespace std;
    typedef long long LL ;
    const int Max_N=100008 ;
    struct Edge{
        int v ;
        int next ;
        LL w ;
    };
    Edge edge[Max_N*2] ;
    int vec[Max_N] ,id ,N;
    inline void add_edge(int u ,int v ,int w){
        edge[id].v=v ;
        edge[id].w=w ;
        edge[id].next=vec[u] ;
        vec[u]=id++ ;
    }
    LL sum ;
    int dfs(int u ,int father){
        int son=1  ;
        for(int e=vec[u];e!=-1;e=edge[e].next){
            int v=edge[e].v ;
            LL w=edge[e].w ;
            if(v!=father){
                int v_son=dfs(v,u) ;
                sum=sum+w*Min(N-v_son,v_son)*2LL ;
                son+=v_son ;
            }
        }
        return son ;
    }
    int main(){
       int T ,u , v , w ;
       scanf("%d",&T)  ;
       for(int ca=1;ca<=T;ca++){
           scanf("%d",&N) ;
           id=0 ;
           fill(vec,vec+1+N,-1) ;
           for(int i=1;i<N;i++){
               scanf("%d%d%d",&u,&v,&w) ;
               add_edge(u,v,w) ;
               add_edge(v,u,w) ;
           }
           sum=0 ;
           dfs(1,-1) ;
           printf("Case #%d: ",ca) ;
           cout<<sum<<endl ;
       }
       return 0 ;
    }
  • 相关阅读:
    Distinct Substrings(spoj 694)
    Musical Theme
    Milk Patterns(poj 3261)
    Repeated Substrings(UVAlive 6869)
    喵星球上的点名(bzoj 2754)
    滑雪与时间胶囊(bzoj 2753)
    莫比乌斯函数之和(51nod 1244)
    欧拉函数之和(51nod 1239)
    数表(bzoj 3529)
    欧拉函数模板
  • 原文地址:https://www.cnblogs.com/liyangtianmen/p/3388733.html
Copyright © 2020-2023  润新知