• 1078 Hashing


    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be ( where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤) and N (≤) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -

    #include <iostream>
    using namespace std;
    int size, n, hashTable[10100];
    bool isprime(int num) {
        if(num == 1) return false;
        for(int i = 2; i * i <= num; i++)
            if(num % i == 0) return false;
        return true;
    }
    void insert(int key) {
        for(int step = 1; step < size; step++) {
            int index = (key + step * step) % size;
            if(hashTable[index] == 0) {
                hashTable[index] = 1;
                cout << index % size;
                return ;
            }
        }
        cout << '-';
    }
    int main() {
        cin >> size >> n;
        while(!isprime(size)) size++;
        for(int i = 0; i < n; i++) {
            int key;
            cin >> key;
            if(i != 0) cout <<' ';
            insert(key);
        }
        return 0;
    }

    柳神代码

    学校的书真lj

  • 相关阅读:
    js获取当前时间
    jQuery动画
    label用js,jquery取值赋值,以及怎么在后台取值
    jquer 事件,选择器,dom操作
    linq分页组合查询
    linq的简单增删改查
    内置对象session ,cookic,Application,ViewState
    listview控件及其与数据库的连接
    Mybatis 学习
    UML类图的6中关系
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11304926.html
Copyright © 2020-2023  润新知