• 1067 Sort with Swap(0, i) 贪心


    1067 Sort with Swap(0, i) (25 分)
     

    Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

    Swap(0, 1) => {4, 1, 2, 0, 3}
    Swap(0, 3) => {4, 1, 2, 3, 0}
    Swap(0, 4) => {0, 1, 2, 3, 4}
    

    Now you are asked to find the minimum number of swaps need to sort the given permutation of the first Nnonnegative integers.

    Input Specification:

    Each input file contains one test case, which gives a positive N (≤) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

    Sample Input:

    10
    3 5 7 2 6 4 9 0 8 1
    

    Sample Output:

    9
    
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n;
    int find(int *arr,int s,int e)
    {
        for(int i=s;i<e;i++)
        {
            if(arr[i]!=i)
            {
                return i;
            }
        }
        return 0;
    }
    void swap(int &a,int &b)
    {
        int temp;
        temp=a;
        a=b;
        b=temp;
    }
    int main()
    {
        int cnt=0,temp;
        cin>>n;
        int * a=new int[n];
        for(int i=0;i<n;i++)
        {
            cin>>temp;
            a[temp]=i;//因为这样查找temp时间复杂度最少
        }
        int pos=1;
        pos=find(a,1,n);
        while(pos)
        {
                if(a[0]==0)
                {
                    a[0]=a[pos];
                    a[pos]=0;
                    cnt++;
                }
                while(a[0]!=0)
                {
                    temp=a[0];
                    a[0]=a[temp];
                    a[temp]=temp;
                    cnt++;
                }
                pos=find(a,pos,n);
        }
        cout<<cnt<<endl;
        return 0;
     } 

    不知道怎么证明是cnt最小的

    如果你够坚强够勇敢,你就能驾驭他们
  • 相关阅读:
    C1FlexGrid双grid滚动条联动
    linux实用命令
    大数据学习1(linux环境搭建)
    一个数据开发工程师要知道的名词
    oracle快速向表插入大量数据
    读书笔记--(索引的扫描方式)
    SQL优化策略(数据仓库)
    oracle大表删除数据方案
    加密与解密
    Spring笔记之IOC
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11187630.html
Copyright © 2020-2023  润新知