• 【poj2676】Sudoku


    Description

    Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

    Input

    The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

    Output

    For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

    Sample Input

    1
    103000509
    002109400
    000704000
    300502006
    060000050
    700803004
    000401000
    009205800
    804000107

    Sample Output

    143628579
    572139468
    986754231
    391542786
    468917352
    725863914
    237481695
    619275843
    854396127

    Source

     
    题解
     
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    int h[10][10],s[10][10],q[10][10],a[10][10];
    int T,flag;
    int getq(int i,int j)
    {
        return (i-1)/3 * 3 +(j-1)/3;
    }
    void dfs(int x)
    {
        if (x>80)     {flag = 1;return;}
        if (a[x/9][x%9] != 0) dfs(x+1);
        else
            if (a[x/9][x%9] == 0)
            {
                int k;
                for (k=1;k<=9;k++)
                    if (h[x/9][k] == 0 && s[x%9][k] == 0 && q[getq(x/9+1,x%9+1)][k] == 0)
                    {
                        h[x/9][k] = s[x%9][k] = q[getq(x/9+1,x%9+1)][k] = 1;
                        {
                            a[x/9][x%9] = k;
                            dfs(x+1);
                            if (flag) return;
                            h[x/9][k] = s[x%9][k] = q[getq(x/9+1,x%9+1)][k] = 0;
                            a[x/9][x%9] = 0;
                        }
                    }
            }
    }
    int main()
    {
        cin>>T;
        while (T--)
        {
            flag = 0;
            memset(h,0,sizeof(h));memset(s,0,sizeof(s));memset(q,0,sizeof(q));
            for (int i=0;i<9;i++)
                for (int j=0;j<9;j++)
                {
                    scanf("%1d",&a[i][j]);
                    h[i][a[i][j]] = 1;
                    s[j][a[i][j]] = 1;
                    q[getq(i+1,j+1)][a[i][j]] = 1;
                }
            dfs(0);
            for (int i=0;i<9;i++)
            {
                for (int j=0;j<9;j++)
                    cout<<a[i][j];
                cout<<endl;
            }
        }    
    }
  • 相关阅读:
    【Solr】copy字段的应用
    【Solr】Solr的安装部署
    【UEditor】 UEditor整合项目上传资源到阿里云服务器
    【Bootstrap】Bootstrap和Java分页-第二篇
    【Bootstrap】Bootstrap和Java分页-第一篇
    工作那点小事
    ubuntu安装mongodb
    mybatis插入返回主键
    linux查看端口占用命令
    ubuntu安装ssh
  • 原文地址:https://www.cnblogs.com/liumengyue/p/5577758.html
Copyright © 2020-2023  润新知