• 【poj2367】Genealogical tree


    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1

    Source

    题解

    求拓扑序列,拓扑排序

    #include<iostream>
    #include<cstdio>
    #define N 110
    using namespace std;
    struct edge_node
    {
        int to,next;
    }e[N*N];
    int head[N];
    int rudu[N];
    int q[N];
    int n,cnt,h,t;
    int main()
    {
        scanf("%d",&n);
        for (int u=1;u<=n;u++)
        {
            int v;
            for (;scanf("%d",&v) && v;)
            {
                e[++cnt].to = v;
                e[cnt].next = head[u];
                head[u] = cnt;
                rudu[v] ++;
            }
        }
        for (int i=1;i<=n;i++)
            if (rudu[i] == 0)
                q[++t] = i;
        for (;h<t;)
        {
            int u = q[++h];
            for (int i = head[u];i;i = e[i].next)
            {
                int v = e[i].to;
                rudu[v] -- ;
                if (!rudu[v])
                    q[++t] = v;
            }
            printf("%d ",u);
        }
    }
  • 相关阅读:
    spring 面试题
    网络安全基础之笔记三(电子邮件安全/IPSec)
    网络安全基础之笔记二(传输层安全)
    网络安全基础之笔记一(用户认证)
    计算机网络基础之笔记一(体系结构)
    计算机网络基础之笔记三(应用层协议)
    计算机网络基础之笔记二(TCP/IP)
    json递归
    js笔试题(不定期更新)
    centos7的安装和配置
  • 原文地址:https://www.cnblogs.com/liumengyue/p/5495523.html
Copyright © 2020-2023  润新知