• PAT Advanced 1031 Hello World for U (20分)


    Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

    h  d
    e  l
    l  r
    lowo
    
     

    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​​ characters, then left to right along the bottom line with n2​​ characters, and finally bottom-up along the vertical line with n3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​​=n3​​=max { k | kn2​​ for all 3 } with n1​​+n2​​+n3​​2=N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:

    helloworld!
    
     

    Sample Output:

    h   !
    e   d
    l   l
    lowor

    这道题目考察了格式化字串,我们需要先补2个位置,除以三,进行计算两边的数量,最后再计算中间的

    #include <iostream>
    using namespace std;
    int main() {
        string str;
        getline(cin, str);
        int row, N = str.length(), recol;
        row = (N + 2) / 3 ;
        recol = (N + 2) / 3 + (N + 2) % 3 - 2;
        for(int i = 0; i < row; i++){
            cout << str[i];
            for(int j = 0; j < recol; j++)
                if(i != row - 1) cout << " ";
                else cout << str[j + row];
            cout << str[N - i -1] << endl;
        }
        return 0;
    }
  • 相关阅读:
    Beacon技术是什么?
    exclude kernel or other packages from getting updated
    (OK) running CORE & docker on Fedora 23 server
    (OK) dnf
    (OK) dnf
    rpm
    dnf
    dnf install -y kernel-4.2.3-300.fc23
    paper4—Multi-MPE_Trigger_Algorithm—testing
    paper4—Multi-MPE_Trigger_Algorithm
  • 原文地址:https://www.cnblogs.com/littlepage/p/12228395.html
Copyright © 2020-2023  润新知