• PAT Advanced 1036 Boys vs Girls (25 分)


    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​gradeM​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA



    #include <iostream>
    using namespace std;
    struct stu{
        string name;
        char gender;
        string id;
        int grade;
    };
    int main()
    {
        int N;cin>>N;
        bool male=false,female=false;
        stu tmp,maleLowest,femaleHighest;
        while(N--){
            cin>>tmp.name>>tmp.gender>>tmp.id>>tmp.grade;
            if(tmp.gender=='M'){
                /**性别为M*/
                if(male==false){
                    male=!male;
                    maleLowest=tmp;
                }else{
                    if(maleLowest.grade>tmp.grade){
                        maleLowest=tmp;
                    }
                }
            }else{
                /**性别为F*/
                if(female==false){
                    female=!female;
                    femaleHighest=tmp;
                }else{
                    if(femaleHighest.grade<tmp.grade){
                        femaleHighest=tmp;
                    }
                }
            }
        }
        /**output*/
        if(female==false) cout<<"Absent"<<endl;
        else cout<<femaleHighest.name<<" "<<femaleHighest.id<<endl;
        if(male==false) cout<<"Absent"<<endl;
        else cout<<maleLowest.name<<" "<<maleLowest.id<<endl;
        if(male==false||female==false) cout<<"NA"<<endl;
        else cout<<(femaleHighest.grade-maleLowest.grade)<<endl;
        system("pause");
        return 0;
    }


  • 相关阅读:
    python16_day18【Django_Form表单、分页】
    python16_day17【Django_session、ajax】
    django【orm操作】
    python16_day16【Django_ORM、模板】
    python16_day15【Django入门】
    python16_day14【jQuery】
    python16_day13【css、js】
    python16_day12【html、css】
    python16_day11【MQ、Redis、Memcache】
    python16_day10【SelectWeb、SelectWget、paramiko、pymysql】
  • 原文地址:https://www.cnblogs.com/littlepage/p/11292215.html
Copyright © 2020-2023  润新知