• POJ3349 Snowflake Snow Snowflakes(Hash)


    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.
    Hash不错的例题,详情见代码注释。
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <algorithm>
    #define P 99991//小于N的最大质数作为模数比较合适,这样Hash值重复的概率比较小 
    #define N 100005 
    using namespace std;
    int n;
    int a[10],tot=0,head[N],next[N],snow[N][6];//暂时存放每片雪花 
    int H(int *a)//每片雪花各个数的和与各个数的积之和作为哈希值比较高效率 
    {
        int sum=0,mul=1;
        int i;
        for(i=0;i<6;i++)
        {
            sum=(sum+a[i])%P;
            mul=(long long)mul*a[i]%P;
        }
        return (sum+mul)%P;//别忘了模一下 
     } 
    bool equal(int *a,int *b)
    {
        int i,j,k;
        for(i=0;i<6;i++)//a从哪一位开始比 
        {
            for(j=0;j<6;j++)//b从哪一位开始比 
            {
                bool eq=1;
                for(k=0;k<6;k++)//a正着 b正着 走k个数 
                {
                    if(a[(i+k)%6]!=b[(j+k)%6])eq=0;
                }
                if(eq)return 1;
                
                eq=1;
                for(k=0;k<6;k++)//a正着 b反着 走k个数 
                {
                    if(a[(i+k)%6]!=b[(j-k+6)%6])eq=0;//为防止出现负数要加上模数 
                }
                if(eq)return 1;
            }
        }
        return 0;//都不行的话return 0 
    }
    bool add(int *a)
    {
        int val=H(a);//获得Hash值
        int i;
        for(i=head[val];i;i=next[i])//类比邻接表进行遍历 
        {
            if(equal(snow[i],a))return 1;//如果相等直接返回1 
        }
        //没找到的话直接插入
        ++tot;//类比邻接表的add操作
        memcpy(snow[tot],a,6*sizeof(int));//把当前新雪花插入表
        next[tot]=head[val];//回忆链表操作 
        head[val]=tot;
        return 0; 
    }
    int main()
    {
        cin>>n;
        int i;
        for(i=1;i<=n;i++)//先从主函数读是一个好习惯 
        {
            int j;
            for(j=0;j<6;j++)
            {
                scanf("%d",&a[j]);
            }
            if(add(a)) 
            {
                cout<<"Twin snowflakes found.";
                return 0;
            }
        }
        cout<<"No two snowflakes are alike.";
        return 0;
    }
  • 相关阅读:
    Datediff的使用(统计本日,昨日,本周,本月)
    数据库之查询语句
    数据库之表关系
    数据库中的数据类型
    数据库概念和基本操作
    IO模型
    并发编程之协程
    GIL与多线程(线程池与进程池,同步异步阻塞非阻塞)
    并发编程之多线程
    并发编程之多进程
  • 原文地址:https://www.cnblogs.com/lipoicyclic/p/12623897.html
Copyright © 2020-2023  润新知