• POJ 1330:Nearest Common Ancestors


    Nearest Common Ancestors
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 20940   Accepted: 11000

    Description

    A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

     
    In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

    For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

    Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

    Output

    Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

    Sample Input

    2
    16
    1 14
    8 5
    10 16
    5 9
    4 6
    8 4
    4 10
    1 13
    6 15
    10 11
    6 7
    10 2
    16 3
    8 1
    16 12
    16 7
    5
    2 3
    3 4
    3 1
    1 5
    3 5
    

    Sample Output

    4
    3
    


    并查集。之前在hihoCoder第十二周做过类似的。

    代码:

    #include <iostream>
    #include <vector>
    #include <string>
    #include <cstring>
    #include <algorithm>
    #pragma warning(disable:4996)
    using namespace std;
    
    int father[10005];
    
    void result(int test1,int test2)
    {
    	int node2=test2;
    	while(father[test1]!=test1)
    	{
    		node2=test2;
    		while(father[node2]!=node2)
    		{
    			if(test1==node2)
    			{
    				cout<<test1<<endl;
    				return;
    			}
    			node2=father[node2];
    		}
    		test1=father[test1];
    	}
    	cout<<test1<<endl;
    	return;
    }
    
    int main()
    {	
    	int count;
    	cin>>count;
    
    	while(count--)
    	{
    		int fa,son,node,i;
    		cin>>node;
    
    		for(i=1;i<10005;i++)
    		{
    			father[i]=i;
    		}
    
    		for(i=1;i<=node-1;i++)
    		{
    			cin>>fa>>son;
    			father[son]=fa;
    		}
    		int test1,test2;
    		cin>>test1>>test2;
    
    		result(test1,test2);		
    	}
    	return 0;
    }
    



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    项目完成 基于Django3.x版本 开发部署小结
    劳动节快乐!手写个核心价值观编码工具 Python实现
    基于.NetCore开发博客项目 StarBlog (4) markdown博客批量导入
    从概念、部署到优化,Kubernetes Ingress 网关的落地实践
    函数计算 HTTP 触发器支持异步,解放双手搭建 Web 服务
    Kruise Rollout: 让所有应用负载都能使用渐进式交付
    比心云平台基于阿里云容器服务 ACK 的弹性架构实践
    云原生×实战派:向业务聚焦,数字创新时代的最佳选择
    阿里云 Serverless 产品技术动态(2022 年 3 月)
    直播预告|企业云原生 IT 成本治理方案解析
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785881.html
Copyright © 2020-2023  润新知