• POJ 3077 : Rounders


    Rounders
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 7827 Accepted: 5062

    Description

    For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on …

    Input
    Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

    Output
    For each integer in the input, display the rounded integer on its own line.

    Note: Round up on fives.

    Sample Input
    9
    15
    14
    4
    5
    99
    12345678
    44444445
    1445
    446

    Sample Output
    20
    10
    4
    5
    100
    10000000
    50000000
    2000
    500

    水题,对一个数,从左到右判定,遇到4先待定,遇到能解决的就可以直接输出。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    int wei[15];
    
    int main()
    {
        int count;
        cin>>count;
    
        while(count--)
        {
            int wang,i,j;
            int str=0;
    
            memset(wei,0,sizeof(wei));
    
            cin>>wang;
    
            i=wang;
    
            while(i)
            {
                wei[++str]=i%10;
                i /=10;
            }
            for(j=str-1;j>=0;j--)
            {
                if(wei[j]==4)
                    continue;
                else if(wei[j]>4)
                {
                    wei[str]++;
                    break;
                }
                else
                    break;
            }
            int result=wei[str]*pow((double)10,str-1);
            cout<<result<<endl;
        }   
        return 0;
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    layout(布局)组件
    accordion(分类)组件
    progressBar(进度条)组件
    LinkButton(按钮)组件
    tooltip(提示框)组件
    jQuery中animate( )的方法及$("body").animate({'scrollTop':top},500)不被Firefox支持问题的解决
    Echarts 图例交互事件
    JSON 语法
    jQueryMobile (一) :教程
    纯CSS3按钮变换效果
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785878.html
Copyright © 2020-2023  润新知