• Uva 439 Knight Moves(骑士游历)


    Knight Moves

    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

    Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

    Input Specification

    The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

    Output Specification

    For each test case, print one line saying "To get from xx to yy takes n knight moves.".

    Sample Input

    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6

    Sample Output

    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.

    #include<stdio.h>
    #include<string.h>
    
    int direction[8][2] = {{-2, -1}, {-2, 1}, {-1, 2}, {1, 2}, {2, 1}, {2, -1}, {1, -2}, {-1, -2}};
    
    int Traverse(int (*maze)[10], int x1, int y1, int x2, int y2, int sum)
    {
        if(x1 == x2 && y1 == y2) return 1;
        for(int t=0; t<8; ++t)
        {
            int i = x1 + direction[t][0], j = y1 + direction[t][1];
            if(0<=i && i<8 && j>=0 && j<8)
            {
                if(maze[i][j] == -1 || (maze[i][j] >= 0 && maze[i][j] > sum))
                {
                    maze[i][j] = sum;
                    Traverse(maze, i, j, x2, y2, sum+1);
                }
            }
        }
        return 1;
    }
    
    int main()
    {
        int maze[10][10], x1, y1, x2, y2;
        char in1[4], in2[4];
        while(scanf("%s%s", in1, in2) != EOF)
        {
            x1 = in1[0] - 'a';
            y1 = in1[1] - '1';
            x2 = in2[0] - 'a';
            y2 = in2[1] - '1';
            memset(maze, -1, sizeof(maze));
            for(int t=0; t<8; ++t)
            {
                maze[x1][y1] = 0;
                int i = x1 + direction[t][0], j = y1 + direction[t][1];
                if(0<=i && i<8 && j>=0 && j<8)
                    {
                        maze[i][j] = 1;
                        Traverse(maze, i, j, x2, y2, 2);
                    }
            }
            printf("To get from %s to %s takes %d knight moves.\n", in1, in2, maze[x2][y2]);
        }
    }

    解题思路:
    还是简单的DFS,不过还是稍微动了一下脑子,比如是一个case,将当前走的步骤数存入到遍历到的当前的那个点里,如果之前已存有值得话,那么将其进行比较

  • 相关阅读:
    js生成当前时间
    《JavaScript权威指南》读书笔记2
    firefox与ie的兼容(css,html)
    兼容ie ff 等浏览器的jquery,js层移动方法一
    解决文字撑大容器的方法,ie,ff, div,table
    兼容ie ff 等浏览器的jquery,js层移动方法二
    【CSS经典问题】子元素浮动之后如何撑开父元素
    【CSS技巧】列表横向排列的另一种方法
    【CSS经典问题】图片下面有空隙的解决办法
    MYSQL主从复制、主主复制、双主多从配置
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2994279.html
Copyright © 2020-2023  润新知