• poj_2481Cows


    Cows
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 9871   Accepted: 3233

    Description

    Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

    Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

    But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj

    For each cow, how many cows are stronger than her? Farmer John needs your help!

    Input

    The input contains multiple test cases. 
    For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

    The end of the input contains a single 0.

    Output

    For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi

    Sample Input

    3
    1 2
    0 3
    3 4
    0
    

    Sample Output

    1 0 0
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 100005;
    typedef struct Node
    {
    	int s;
    	int e;
    	int pos;
    }Node;
    Node node[MAXN];
    int tree[MAXN];
    int level[MAXN];
    
    bool cmp(Node x,Node y)
    {
    	if(x.e == y.e) return x.s < y.s;
    	else return x.e > y.e;
    }
    
    int LowBit(int t)
    {
    	return t&(-t);  
    }
    
    void Update(int pos, int num)
    {
    	while(pos <= MAXN)
    	{
    		tree[pos] += num;
    		pos += LowBit(pos);
    	}
    }
    
    int GetSum(int end)
    {
    	int sum = 0;
    	while(end > 0)
    	{
    		sum += tree[end];
    		end -= LowBit(end);
    	}
    	return sum;
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int n, x, y;
    	while(scanf("%d", &n) != EOF)
    	{
    		memset(tree, 0, sizeof(tree));
    		if(n==0)
    		{
    			break;
    		}
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%d %d", &x, &y);
    			node[i].pos = i;
    			node[i].s = x + 1;
    			node[i].e = y + 1;
    		}
    		sort(node + 1, node + n + 1, cmp);
    		for (int i = 1; i <= n; i++)
    		{
    			cout << node[i].pos << " " << node[i].s << " " << node[i].e << endl;
    		}
    		for(int i = 1; i <= n; i++)
    		{
    			Update(node[i].s, 1);
    			level[node[i].pos] = GetSum(node[i].s) - 1;
    		}
    		for (int i = 1; i < n; i++)
    		{
    			printf("%d ", level[i]);
    		}
    		printf("%d\n", level[n]);
    	}
    }
    

    9
    5 5
    5 6
    1 4
    4 5
    1 4
    4 6
    2 3
    3 5
    1 4
    
    4 1 0 2 0 0 3 0 0
    没有考虑相同的点,导致WA,后来想一想,这样也不能满足Ei - Si > Ej - Sj。也就是说排除两组数据相同的情况,任何满足 Si <= Sj and Ej <= Ei 的必然会满足Ei - Si > Ej - Sj。

    AC代码:

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 100005;
    typedef struct Node
    {
    	int s;
    	int e;
    	int pos;
    }Node;
    Node node[MAXN];
    int tree[MAXN];
    int level[MAXN];
    
    bool cmp(Node x,Node y)
    {
    	if(x.e == y.e) return x.s < y.s;
    	else return x.e > y.e;
    }
    
    int LowBit(int t)
    {
    	return t&(-t);  
    }
    
    void Update(int pos, int num)
    {
    	while(pos <= MAXN)
    	{
    		tree[pos] += num;
    		pos += LowBit(pos);
    	}
    }
    
    int GetSum(int end)
    {
    	int sum = 0;
    	while(end > 0)
    	{
    		sum += tree[end];
    		end -= LowBit(end);
    	}
    	return sum;
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int n, x, y;
    	while(scanf("%d", &n) != EOF)
    	{
    		memset(tree, 0, sizeof(tree));
    		if(n == 0)
    		{
    			break;
    		}
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%d %d", &x, &y);
    			node[i].pos = i;
    			node[i].s = x + 1;
    			node[i].e = y + 1;
    		}
    		sort(node + 1, node + n + 1, cmp);
    		/*for (int i = 1; i <= n; i++)
    		{
    			cout << node[i].pos << " " << node[i].s << " " << node[i].e << endl;
    		}*/
    		Update(node[1].s, 1);
    		level[node[1].pos] = GetSum(node[1].s) - 1;
    		x = node[1].s;
    		y = node[1].e;
    		for(int i = 2; i <= n; i++)
    		{
    			if(node[i].s == x && node[i].e == y)
    			{
    				level[node[i].pos] = level[node[i-1].pos];
    				Update(node[i].s, 1);
    				continue;
    			}
    			x = node[i].s;
    			y = node[i].e;
    			Update(node[i].s, 1);
    			level[node[i].pos] = GetSum(node[i].s) - 1;
    		}
    		for (int i = 1; i < n; i++)
    		{
    			printf("%d ", level[i]);
    		}
    		printf("%d\n", level[n]);
    	}
    }
    




  • 相关阅读:
    thinkphp的钩子的两种配置和两种调用方法
    php闭包实现函数的自调用,也是递归
    php的spl_autoload_register函数的一点个人见解
    详解js变量、作用域及内存
    关于js的call()和apply()两个函数的一点个人看法
    php实现斐波那契数列以及由此引起的联想
    php猴子称王或者约瑟夫难题
    Linux Bash Shell 快速入门
    Fedora14下首次搭建Samba服务器遇到的一些问题
    【JavaScript】我的JavaScript技术总结第一篇——编程细节
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834984.html
Copyright © 2020-2023  润新知