• Symmetric Order


    Description

    In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.

    Input

    The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

    Output

    For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.

    Sample Input

    7
    Bo
    Pat
    Jean
    Kevin
    Claude
    William
    Marybeth
    6
    Jim
    Ben
    Zoe
    Joey
    Frederick
    Annabelle
    5
    John
    Bill
    Fran
    Stan
    Cece
    0
    

    Sample Output

    SET 1
    Bo
    Jean
    Claude
    Marybeth
    William
    Kevin
    Pat
    SET 2
    Jim
    Zoe
    Frederick
    Annabelle
    Joey
    Ben
    SET 3
    John
    Fran
    Cece
    Stan
    Bill
    
    
    
    
    #include <iostream>
    #include <string>
    using namespace std;
    string a[100],b[100];
    int main()
    {
    int t=0,n,j,i,k;
    while(cin>>n,n!=0)
    {t++;j=1;k=0;
    for(i=1;i<=n;i++)
    cin>>a[i];
    for(i=1;i<=n;i++)
    {if(i%2!=0)
    {b[j]=a[i];j++;}
    else
    {b[n-k]=a[i];k++;}
    }
    cout<<"SET "<<t<<endl;
    for(i=1;i<=n;i++)
    cout<<b[i]<<endl;
    
    
    
    
    }
    
    return 0;}
     
  • 相关阅读:
    solr初步了解
    jieba初步了解
    情感计算emokit
    常用命令
    java跨域访问问题记录
    mysql 免安装版配置
    Android 图片缩放方法
    spring android http
    sql join 与where的区别
    android activitygroup 使用
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387838.html
Copyright © 2020-2023  润新知