• pat1019-简单模拟题


    1019. General Palindromic Number (20)

    时间限制
    400 ms
    内存限制
    32000 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

    Sample Input 1:
    27 2
    
    Sample Output 1:
    Yes
    1 1 0 1 1
    
    Sample Input 2:
    121 5
    
    Sample Output 2:
    No
    4 4 1

    源程序:
        #include<iostream>
        using namespace std;
        int main(){
            int N,base,Bsize=0;
            int buf[1002];                   //数组内容未初始化
            cin>>N>>base;
            if((N>=0)&&(base>=2)){           //注意值的取值边界,不要漏取。此处忽略了N取0的情况,导致一个测试case不过
            while(N!=0){
                    buf[Bsize++]= N % base;  //注意数组成员数量变量Bsize的值的变化,最后一次运算后,其值会+1
                    N=N/base;
            }
    
         bool flag=true;
         for(int i=0,j=Bsize-1;i<=j;i++,j--){
                if(buf[i]!=buf[j]){
                flag=false;
                break;
                }
         }
         if(flag){
            cout<<"Yes"<<endl;
            }else{
                 cout<<"No"<<endl;
            }
         for(int j=Bsize-1;j>0;j--)
                cout<<buf[j]<<" ";        //关于首尾部位的格式控制
                cout<<buf[0];
            }
    
             return 0;
        }

  • 相关阅读:
    $(document).ready(function() {。。。。。})里面的所有的代码都不执行(不执行初始化脚本)
    checkbox使用示例
    js中数组元素的添加和删除
    maven构建项目里classpath的位置
    Docker相关释义
    linux的systemctl服务及其使用
    RabbitMQ中客户端的Channel类里各方法释义
    java四种内部类详解
    生成随机字符串(三种方式)
    RabbitMQ在java中基础使用
  • 原文地址:https://www.cnblogs.com/lazyboy-yan/p/3557478.html
Copyright © 2020-2023  润新知