• hdu6312 2018杭电多校第二场 1004 D Game 博弈


    Game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 184    Accepted Submission(s): 132


    Problem Description
    Alice and Bob are playing a game.
    The game is played on a set of positive integers from 1 to n.
    In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored.
    Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses.
    Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.
     
    Input
    There might be multiple test cases, no more than 10. You need to read till the end of input.
    For each test case, a line containing an integer n. (1n500)
     
    Output
    A line for each test case, 'Yes' or 'No'.
     
    Sample Input
    1
     
    Sample Output
    Yes
     
    Source
     
    Recommend
    chendu   |   We have carefully selected several similar problems for you:  6318 6317 6316 6315 6314 
     
    题意:给你一串数字,A和B分别可以对这串数字进行操作,每次操作可以删去一个数及他所有的因子,轮到谁时谁无法再进行操作谁就输了
    首先考虑1-n,我们可以先不看1,则2-n一定有一个胜者,如果这个状态A胜的话,我们就可以选择那个让我们胜的数,因为1是所有数的因子所以1也会被删去,如果A输,我们可以先去掉1来转变状态。这样A还是会胜。
    综述A一定会获胜
     
    #include<iostream>
    using namespace std;
    int main() {
        int n;
        while( cin >> n ) {
            cout << "Yes" << endl;
        }
        return 0;
    }
    

      

    彼时当年少,莫负好时光。
  • 相关阅读:
    2.分布式锁
    1. junit用法,before,beforeClass,test,after, afterClass的执行顺序
    GC算法
    记一次"截图"功能的前期调研过程!
    程序员转行手册!
    Yarn详细的工作流程
    Yarn的三种调度器(Scheduler)
    Hadoop序列化与Java序列化的区别
    MapReduce执行过程
    从普通登录到单点登录图例
  • 原文地址:https://www.cnblogs.com/l609929321/p/9368581.html
Copyright © 2020-2023  润新知