• 最长上升子序列模板 hdu 1087 Super Jumping! Jumping! Jumping!


    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 

    InputInput contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 
    OutputFor each case, print the maximum according to rules, and one line one case. 
    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3

    求一串递增的数字总和的最大值

    借这里放下最长上升子序列的模板(求最大长度和最大总和的)

    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdlib>
    #include<cstdio>
    #include<string>
    #include<cmath>
    #define debug(a) cout << #a << " " << a << endl
    using namespace std;
    typedef long long ll;
    const int inf = 1e9;
    int a[1010], dp[1010], num[1010], n;
    int calc( int sign ) { //求最长,nlog(n)
        fill( dp, dp+1010, inf );
        int ans = 0;
        for( int i = 0; i < n; i ++ ) {
            int index = lower_bound( dp, dp+ans, a[i]*sign ) - dp; //lower为求严格递增,upper为求非严格递增
            dp[index] = a[i]*sign;
            ans = max( ans, index + 1 );
        }
        return ans;
    }
    int lins() {
        return calc(1);
    }
    int lnds() {
        return calc(-1);
    }
    int calc_max() { //求最大,n^2
        int ans = 0;
        for( int i = 0; i < n; i ++ ) {
            dp[i] = a[i];
            for( int j = 0; j < i; j ++ ) {
                if( a[j] < a[i] ) {
                    dp[i] = max( dp[i], dp[j]+a[i] );
                }
            }
            ans = max( ans, dp[i] );
        }
        return ans;
    }
    int main() {
        std::ios::sync_with_stdio(false);
        while( cin >> n ) {
            memset( num, 0, sizeof(num) );
            if( !n ) {
                break;
            }
            for( int i = 0; i < n; i ++ ) {
                cin >> a[i];
            }
            cout << calc_max() << endl;
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    第一章
    第三章
    第四章
    第十章 读书笔记
    第八章 读书笔记
    第九章 读书笔记
    第7章实验心得
    第六章实验心得
    第五章心得体会
    第四章实验心得
  • 原文地址:https://www.cnblogs.com/l609929321/p/9015980.html
Copyright © 2020-2023  润新知