• POJ 2689 Prime Distance(大区间素数筛选)


    Prime Distance
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9322   Accepted: 2531

    Description

    The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
    Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

    Input

    Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

    Output

    For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

    Sample Input

    2 17
    14 17
    

    Sample Output

    2,3 are closest, 7,11 are most distant.
    There are no adjacent primes.
    

    Source

     
     
    /*
     * POJ 2689 Prime Distance
     * 给出一个区间[L,U],找出区间内容、相邻的距离最近的两个素数和
     * 距离最远的两个素数。
     * 1<=L<U<=2,147,483,647 区间长度不超过1,000,000
     * 就是要筛选出[L,U]之间的素数
     */
    
    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    #include <string.h>
    using namespace std;
    
    const int MAXN=100010;
    int prime[MAXN+1];
    void getPrime()
    {
        memset(prime,0,sizeof(prime));
        for(int i=2;i<=MAXN;i++)
        {
            if(!prime[i])prime[++prime[0]]=i;
            for(int j=1;j<=prime[0]&&prime[j]<=MAXN/i;j++)
            {
                prime[prime[j]*i]=1;
                if(i%prime[j]==0)break;
            }
        }
    }
    bool notprime[1000010];
    int prime2[1000010];
    void getPrime2(int L,int R)
    {
        memset(notprime,false,sizeof(notprime));
        if(L<2)L=2;
        for(int i=1;i<=prime[0]&&(long long)prime[i]*prime[i]<=R;i++)
        {
            int s=L/prime[i]+(L%prime[i]>0);
            if(s==1)s=2;
            for(int j=s;(long long)j*prime[i]<=R;j++)
                if((long long)j*prime[i]>=L)
                    notprime[j*prime[i]-L]=true;
        }
        prime2[0]=0;
        for(int i=0;i<=R-L;i++)
            if(!notprime[i])
                prime2[++prime2[0]]=i+L;
    }
    int main()
    {
        getPrime();
        int L,U;
        while(scanf("%d%d",&L,&U)==2)
        {
            getPrime2(L,U);
            if(prime2[0]<2)printf("There are no adjacent primes.\n");
            else
            {
                int x1=0,x2=100000000,y1=0,y2=0;
                for(int i=1;i<prime2[0];i++)
                {
                    if(prime2[i+1]-prime2[i]<x2-x1)
                    {
                        x1=prime2[i];
                        x2=prime2[i+1];
                    }
                    if(prime2[i+1]-prime2[i]>y2-y1)
                    {
                        y1=prime2[i];
                        y2=prime2[i+1];
                    }
                }
                printf("%d,%d are closest, %d,%d are most distant.\n",x1,x2,y1,y2);
            }
        }
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    php在没用xdebug等调试工具的情况下如何让调试内容优雅地展现出来?--php数组格式化
    linux自动定时备份web程序和mysql数据库
    linux下用cronolog分割apache日志
    写在前面--点燃酱爆心中的那团火
    我对知乎前端相关问题的十问十答(转)
    参考美团、饿了么 && localStorage
    vue-scroller的使用 && 开发自己的 scroll 插件
    如何发布一个包到npm && 如何使用自己发布的npm包 && 如何更新发布到npm的package && 如何更新当前项目的包?
    VUE中toast的使用与开发
    如何在vue && webpack 项目中的单文件组件中引入css
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3089840.html
Copyright © 2020-2023  润新知