• HDU 1325 Is It A Tree? POJ 1308 Is It A Tree? (并查集+入度,判断一个有向图是树)


    Is It A Tree?
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 17328   Accepted: 5934

    Description

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

    There is exactly one node, called the root, to which no directed edges point. 
    Every node except the root has exactly one edge pointing to it. 
    There is a unique sequence of directed edges from the root to each node. 
    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

    Input

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

    Output

    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

    Sample Input

    6 8  5 3  5 2  6 4
    5 6  0 0
    
    8 1  7 3  6 2  8 9  7 5
    7 4  7 8  7 6  0 0
    
    3 8  6 8  6 4
    5 3  5 6  5 2  0 0
    -1 -1

    Sample Output

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.

    Source

     
     
     
     
    这题用并查集判断连通,连通后有且仅有1个入度为0,其余入度为1,就是树了。
    注意树为空的情况。
     
    结点要记录出现的结点。
     
    /*
    HDU 1325     POJ  1308
    用并查集判断连通,然后根据入度,只有一个入度为0的
    其余入度为0
    注意为空的情况。
    用数组记录出现了的结点。
    */
    
    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    #include <string.h>
    using namespace std;
    
    const int MAXN=1000000;
    int a[MAXN];
    int F[MAXN];
    int in[MAXN];
    bool used[MAXN];
    
    int find(int x)
    {
        if(F[x]==-1)return x;
        else return F[x]=find(F[x]);
    }
    void bing(int x,int y)
    {
        int t1=find(x);
        int t2=find(y);
        if(t1!=t2)F[t1]=t2;
    }
    int main()
    {
        int cnt=0;
        int u,v;
        int iCase=0;
        bool flag=true;
        memset(F,-1,sizeof(F));
        memset(used,false,sizeof(used));
        memset(in,0,sizeof(in));
        while(scanf("%d%d",&u,&v)==2)
        {
            if(u==-1 && v==-1)break;
            if(u==0 && v==0)
            {
                iCase++;
                printf("Case %d ",iCase);
                int t0=0;
                for(int i=0;i<cnt;i++)
                {
                    if(find(a[i])!=find(a[0]))
                    {
                        flag=false;
                        break;
                    }
                    if(in[a[i]]==0)t0++;
                    else if(in[a[i]]>1)
                    {
                        flag=false;
                        break;
                    }
                }
                if(t0!=1)flag=false;
                if(cnt==0)flag=true;
                if(flag)printf("is a tree.\n");
                else printf("is not a tree.\n");
    
                cnt=0;
                memset(F,-1,sizeof(F));
                memset(used,false,sizeof(used));
                memset(in,0,sizeof(in));
                flag=true;
            }
            else
            {
                if(!used[u])
                {
                    used[u]=true;
                    a[cnt++]=u;
                }
                if(!used[v])
                {
                    used[v]=true;
                    a[cnt++]=v;
                }
                if(find(u)==find(v))flag=false;
                else
                {
                    bing(u,v);
                    in[v]++;
                }
            }
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    C 语言中字符的输入输出
    C 语言 ctype.h 中系列字符处理函数
    C 语言中 for 循环的几种用法
    C 中优先级和关系运算符
    字符串和格式化输入/输出 [printf & scanf]
    C++中关于string类的一些API总结
    两大基本数据类型
    这些时候的总结
    PL/SQL 十进制数转任意进制
    复现题目[CISCN 2019 华东北赛区 Web2 WriteUp](https://www.zhaoj.in/read-6100.html)的一些东西
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2996364.html
Copyright © 2020-2023  润新知