• ZOJ 3203 Light Bulb (数学直接推公式 或者 三分法)


    ZOJ Problem Set - 3203
    Light Bulb

    Time Limit: 1 Second      Memory Limit: 32768 KB

    Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

    Input

    The first line of the input contains an integer T (T <= 100), indicating the number of cases.

    Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

    Output

    For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

    Sample Input

    3
    2 1 0.5
    2 0.5 3
    4 3 4
    

    Sample Output

    1.000
    0.750
    4.000
    
    本来此题直接推出了公式,直接找到了最值点的。
    但是看到网上好多用三分法做的,就复习了下三分法,因为是凸的,所以用三分。
     
     
    公式法:
    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
       // freopen("in.txt","r",stdin);
       // freopen("out.txt","w",stdout);
        int T;
        double H,h,D;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%lf%lf%lf",&H,&h,&D);
            double temp=sqrt((H-h)*D);
            double temp2=(H-h)*D/H;
            if(temp>=D)printf("%.3lf\n",h);
            else if(temp<temp2)printf("%.3lf\n",h*D/H);
            else
            {
                double ans=D+H-temp-(H-h)*D/temp;
                printf("%.3lf\n",ans);
            }
        }
        return 0;
    }

    三分法:

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<math.h>
    using namespace std;
    const double eps=1e-9;
    double D,H,h;
    
    
    double calc(double x)
    {
        return D-x+H-(H-h)*D/x;
    }
    
    double solve(double l,double r)
    {
        double mid,midmid;
        double d1,d2;
        do
        {
            mid=(l+r)/2;
            midmid=(mid+r)/2;
            d1=calc(mid);
            d2=calc(midmid);
            if(d1>=d2) r=midmid;//这里要注意
            else l=mid;
        }
        while(r-l>=eps);
        return d1;
    }
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%lf%lf%lf",&H,&h,&D);
            printf("%.3lf\n",solve((H-h)*D/H,D));
        }
        return 0;
    }
  • 相关阅读:
    python-异常处理总结
    python-笔记-内置函数
    python练习题--计算总分平均分操作excel
    python-笔记(操作excel)
    python -加密(MD5)
    jmeter-http信息头管理器
    python-判断一个字符串是不是小数
    [Python] [Django] Django将post请求变成get
    离线安装rabbitmq
    python第三方包的几种安装方式
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2705751.html
Copyright © 2020-2023  润新知