• HDU 1036 Average is not Fast Enough!(水题)


    Average is not Fast Enough!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2189    Accepted Submission(s): 856


    Problem Description
    A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

    You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
    So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
     
    Input
    The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
     
    Output
    For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
     
    Sample Input
    2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
     
    Sample Output
    5: 3:52 min/km 42: - 7: 6:00 min/km
     
    Source
     
     
     
    很简单。。。
    就是要注意输入和输出格式。。。注意细节呢
     
     
    #include<stdio.h>
    int main()
    {
        int n;
        double d;
        int num;
        char h,m1,m2,s1,s2;
        scanf("%d",&n);
        scanf("%lf",&d);
        while(scanf("%d",&num)!=EOF)
        {
            
            printf("%3d: ",num);
            bool flag=true;
            int sumtime=0;
            for(int i=0;i<n;i++)
            {getchar();
                scanf("%c:%c%c:%c%c",&h,&m1,&m2,&s1,&s2);
                if(h=='-') flag=false;
                if(flag==false)continue;
                sumtime+=(h-'0')*3600+((m1-'0')*10+(m2-'0'))*60+(s1-'0')*10+(s2-'0');
            }    
            if(flag==false)printf("-\n");
            else
            {
                double t1=sumtime/d;
                int t2=(int)(t1+0.5);
                printf("%d:%02d min/km\n",t2/60,t2%60);
                
            }    
        }    
        return 0;
    }    
  • 相关阅读:
    DevExpress 最最最基础踩坑(如何设置控件属性)
    Oracle如何创建数据库(使用图形化界面,顺便提一下UTF-8和ZB16GB字符集的问题)
    ElementUI el-dialog中嵌套子页面
    Oracle详细教程(触发器,事务,存储过程,锁,游标)
    和人事交谈下来的几点感悟
    Oracle Groupby分组缺少表达式解决方法
    leetcode973. 最接近原点的 K 个点(谈谈C#中的Icomparer,ComParer,IComparable)
    APP的闪退和无响应
    APP测试的主要内容
    python数据结构
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2533315.html
Copyright © 2020-2023  润新知