• ACM HDU 1851 A Simple Game(博弈)


    A Simple Game

    Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/65535K (Java/Other)
    Total Submission(s) : 2   Accepted Submission(s) : 2
    Problem Description
    Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M1 stones, the 2nd pile has M2 stones, ... and the n-th pile contain Mn stones. Agrael and Animal take turns to move and in each move each of the players can take at most L1 stones from the 1st pile or take at most L2 stones from the 2nd pile or ... or take Ln stones from the n-th pile. The player who takes the last stone wins.

    After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

    The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
     

    Input
    The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers Mi and Li (20 ≥ Mi > 0, 20 ≥ Li > 0).
     

    Output
    Your program output one line per case, if Agrael can win the game print "Yes", else print "No".
     

    Sample Input
    2
    1
    5 4
    2
    1 1
    2 2
     

    Sample Output
    Yes
    No
     

    Author
    Agreal@TJU
     

    Source
    HDU 2007 Programming Contest - Final
     

    题意:n堆石子,分别有M1,M2,·······,Mn个石子,各堆分别最多取L1,L2,·····Ln个石头,两个人分别取,一次只能从一堆中取,取走最后一个石子的人获胜。后选的人获胜输出Yes,否则输出No,

    第一行一个数字表示数据有多少组,每组测试数据第一行是一个整数n,表示有n行,然后n行分别是两个整数Mi,Li. 表示第i堆有Mi个石子,一次最多去Li个石子。

    代码:

    #include<stdio.h>
    int main()
    {
    int T;
    int i,n;
    int ans,m,l;
    scanf(
    "%d",&T);
    while(T--)
    {
    scanf(
    "%d",&n);
    ans
    =0;
    for(i=1;i<=n;i++)
    {
    scanf(
    "%d%d",&m,&l);
    ans
    =ans^(m%(l+1));
    }
    if(ans==0) printf("Yes\n");//后取的人胜
    else printf("No\n");//先取的人胜
    }
    return 0;
    }

  • 相关阅读:
    sizeof,终极无惑(上)
    send,recv,sendto,recvfrom
    【问卷调查】社团对海大学生成长的影响研究(及部分调查结果)
    Opencv cvCircle函数
    墨菲定律、二八法则、马太效应、手表定理、“不值得”定律、彼得原理、零和游戏、华盛顿合作规律、酒与污水定律、水桶定律、蘑菇管理原理、钱的问题、奥卡姆剃刀等13条是左右人生的金科玉律
    C#操作Excel文件(读取Excel,写入Excel)
    秋风秋雨愁煞人
    Java Applet读写client串口——终极篇
    数据库索引的作用和长处缺点
    EasyARM i.mx28学习笔记——开箱试用总结
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2158950.html
Copyright © 2020-2023  润新知